Results 1 to 2 of 2

Thread: Grid not rendering in IE8 (fine in FF)

  1. #1
    Sencha User
    Join Date
    May 2009
    Location
    Paris, France
    Posts
    10

    Default Grid not rendering in IE8 (fine in FF)

    See below screenshots from Internet Explorer 8 and Firefox 3.6
    I'm using a GridPanel, XmlStore and XmlReader. Left screenshot is from FF and is showing data as expected. Apparently, data is loading from the server with IE8 as row headers are showing, but as you can see other columns don't show.
    Is this a well-known problem or should I post my code for further investigation?
    Thanks in advance for any help!

    EDIT: SOLVED
    The problem was with string.substr(-X,Y) not working in IE. Nothing to do with ExtJS.
    Attached Images Attached Images

  2. #2

    Default

    I don't have a specific answer for you, but I can make this observation: sometimes the timing of event-handling is subtly different between IE and FF. Look over the sequence of events that you are using, and consider adding 100 milliseconds or so of delay in some of the event-listener specs.

    Basically, it's possible that you could be getting an event that signals that something's supposed to be ready, and responding to it immediately, when actually it's going to be ready in a few milliseconds. Mind you: it's not supposed to be this way, but sometimes it is. It's purely an artifact of the browser implementation, plus maybe the phase of the moon. All you can do is to code around it. "A spoonful of delay makes the medicine go down ..."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •