Results 1 to 2 of 2

Thread: GridPanel not rendering and loading data inconsistantly

  1. #1
    Ext User
    Join Date
    Nov 2009
    Posts
    12

    Default GridPanel not rendering and loading data inconsistantly

    Hi there i have a little problem. I am dynamically creating and destrying panels which hold gridpanels. each time a gridpanel panel is created, the jsonstore get a new set of data which is used to populate the grid.

    what i am finding is that when the panel is loaded, the gridpanel is not displaying correctly (ref image). Also i can repeatedly use the same data response for many consecutive creates of the panel, but when i do this, somtimes the response loads into the grid and sometimes not. randem eh..

    as a side note, i am not sure if this would effect anything, but i am also using Darg and drop on the grid.

    Here is the code i have written. the two controls in question are
    store_CSVAttributes
    and
    _store_CSVAttributes

    the DataAttribute stuff is working fine.

    also here is an extract of the response i am getting back from the server:
    Code:
    {success:true,fields:[{name:'1'},{name:'2'},{name:'3'},{name:'4'}], count:4}
    Last edited by MrTim; 22 Feb 2010 at 5:57 AM. Reason: Add Image File

  2. #2
    Ext User
    Join Date
    May 2010
    Location
    China, Zhejiang province, Ningbo City, a small city of 5 million people..
    Posts
    12

    Default load data before grid

    Maybe it's a problem of loading data store BEFORE loading the grid or panel.
    Use callback functions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •