Results 1 to 2 of 2

Thread: extjs and Selenium not working?

  1. #1
    Sencha User
    Join Date
    Aug 2008
    Posts
    42

    Question extjs and Selenium not working?

    I have tons of Selenium tests that run perfect before I load the extjs framework. Than I load the initial page of the application (including extjs), building everything, ...

    ... and can't get any xpath expression to work. When I navigate to the page with the browser I can use XPather (Firefox plugin) to verify that the elemtns (ie a[@id="enter-company-data"]) exist. When I try to access them in the test I get null. Always. Starts with the body-tag (with id) which is plan html - the same test succeeds without any problem on the page before (only difference: extjs is not loaded).

    I can't access Ext from Selenium as well (in the eval-javascript method it tells me that Ext is undefined).

    Anybody the same problems or an idea for the solution?

    Tnx and best regards,

    Anton

    P.S.: When I implement a wait before I try to access the element nothing changes in the behaviour as expected, but when I click on the link (which reloads another part of the page) suddenly Selenium knows the link which it totaly ignored before. Is there a way to "refresh" the DOM model of selenium?
    Last edited by abtrapp; 18 Dec 2009 at 4:56 AM. Reason: new behaviour

  2. #2
    Sencha User
    Join Date
    Aug 2008
    Posts
    42

    Thumbs up elements not found

    Great!

    I am such an *****. Menu items in submenus are created after ther top level menu is displayed...

    Forget my post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •