Results 1 to 6 of 6

Thread: Page will not work in IE

  1. #1
    Sencha User
    Join Date
    Jul 2009
    Posts
    38

    Default Page will not work in IE

    I have a page which contains a viewport (consisting of a gridpanel and several other panels).

    Everything works perfectly in Firefox, but I just noticed it doesn't work in IE. All I get is a blank screen and this error:

    'events' is null or not an object.

    The error refers to line 17622 which i assume is in ext-all-debug

    The line is part of this function:

    Code:
    17618 lookupComponent : function(comp){ 
    17619        if(typeof comp == 'string'){ 
    17620            return Ext.ComponentMgr.get(comp); 
    17621        }else if(!comp.events){ 
    17622            return this.createComponent(comp); 
    17623        } 
    17624        return comp;
    Any ideas what might be causing this?

    Cheers

  2. #2

  3. #3
    Sencha User carol.ext's Avatar
    Join Date
    Jun 2007
    Location
    Littleton, Colorado, USA
    Posts
    707

    Default

    I left my crystal ball at home, but suggest taking a look at the Internet Explorer section of the debugging FAQ.

  4. #4
    Sencha User Animal's Avatar
    Join Date
    Mar 2007
    Location
    Bédoin/Nottingham
    Posts
    30,890

    Default

    I predict that it's a trailing comma in an items config meaning that the last element is undefined which is passed to lookupComponent.

  5. #5
    Sencha User
    Join Date
    Jul 2009
    Posts
    38

    Default

    Hmm not sure how but I fixed it. I stuck all my code into JSlint (before I saw your replies) to see what that gave me and it came up with a bunch of errors, most involving my custom renderers. I temporarily deleted them and IE worked. I put them back in again, and now it still works?! Its definitely not cached as I've done forced resets...weird.

    Only thing is, for some reason a couple of my elements are being rendered off the screen in IE, but not in Firefox. In my north region, I have a panel containing items (in this order): an image, a triggerfield and a combo. For some reason, the triggerfield and combo box are being rendered off the right side of the page (can get to them using Tab). I'm using the hbox layout. They appear fine in Firefox.

  6. #6
    Sencha User Animal's Avatar
    Join Date
    Mar 2007
    Location
    Bédoin/Nottingham
    Posts
    30,890

    Default

    Sounds like an overnest.

    "in my north region I have a panel containing...."

    Alarm bells.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •