Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: DirectCFM: A ColdFusion Server-side Stack

  1. #31
    Ext JS Premium Member Gjslick's Avatar
    Join Date
    Feb 2009
    NJ, USA


    Hey Aaron, just posted my application instantiated version of the stack. It's located here: It was really originally just for the implementation of my site, but I tried to make customizable enough for others as well. Anyway, take a look and let me know what you think

    Thanks again for your great example stack btw, really got me going on this.


  2. #32

    Default Var patch

    I ran over my project recently with the VarScoper tool, and it found a few missed vars.

    Patch attached.
    Attached Files Attached Files

  3. #33
    Sencha User
    Join Date
    Jun 2012


    Dear Aaron Conran,

    In version v0.1 DirectCFM, when I run the code on a server Coldfusion 9 it is returning the following exception:

    18:08:23.023 - java.lang.NegativeArraySizeException - in C: \ wamp \ www \ cfdirect \ ServiceBus \ Direct.cfc: line 13

    The line in question is the following:
    var byteArray = CreateObject ("java", "java.lang.reflect.Array"). newInstance (byteClass, size);

    The DirectCFM be incompatible to the ColdFusion 9?

    Vitor Rodrigues S

  4. #34
    Ext JS Premium Member CutterBl's Avatar
    Join Date
    Aug 2007
    Nashville, TN

    Cool Negative Array Size


    I'm not sure what is causing your issue, but it isn't CF 9 itself. I wrote the Ext Direct chapter of Learning Ext JS 3.2 using ColdFusion 9 for the sample code, and all worked well. You may want to look deeper, like did you add the custom attributes to your component and methods?
    Steve "Cutter" Blades
    Adobe Certified Professional - Advanced Macromedia ColdFusion MX 7 Developer

    Blog: Cutter's Crossing

    Co-Author "Learning Ext JS 3.2"

  5. #35
    Sencha User
    Join Date
    Jun 2012



    Excuse me, the problem was lack of attention. The path was wrong.

    It worked perfectly now, and I noticed that not all the original files on Aaron Conran run directly in browser.

    When you run the link http://localhost/cfdirect/servicebus/Api.cfm the return of the browser:
    Ext.ns(''); = {"url":"servicebus\/Router.cfm","namespace":"","type":"remoting","actions":{"echo":[{"len":1,"name":"send"}],"gridExample":[{"len":1,"name":"addGame"},{"len":2,"name":"updateGame"},{"len":1,"name":"deleteGame"},{"len":4,"name":"getGames"}]}};
    When you run the link http://localhost/cfdirect/servicebus/Direct.cfc, I'm redirected to the CFCExplorer Coldfusion Application Server.

    And when running http://localhost/cfdirect/servicebus/Router.cfm link, I get the following message:

    Error Occurred While Processing Request
    The error occurred in C:\wamp\www\cfdirect\servicebus\Direct.cfc: line 10
    8 : var emptyByteArray = createObject("java", "").init().toByteArray();9 : var byteClass = createObject("java","java.lang.Byte").TYPE;10 : var byteArray = createObject("java","java.lang.reflect.Array").newInstance(byteClass, size);11 : GetPageContext().getRequest().getInputStream().readLine(byteArray, 0, size);12 : createObject('java', 'java.lang.System').out.println("{GetJSONRequest} ByteArray.ToString=" &ToString( byteArray ) );

    Browser Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.47 Safari/536.11
    Remote Address
    Referrer http://localhost/cfdirect/servicebus/
    Date/Time 02-Jul-12 08:30 PM
    Stack Trace
    at cfDirect2ecfc1912446458$funcGETPOSTBODY.runFunction(C:\wamp\www\cfdirect\servicebus\Direct.cfc:10) at cfRouter2ecfm1678883259.runPage(C:\wamp\www\cfdirect\servicebus\Router.cfm:33)

    java.lang.NegativeArraySizeException at java.lang.reflect.Array.newArray(Native Method)

    My development environment is as follows:
    - 2.40GHz Core I3
    - 4GB DDR3
    - 1 TB SATA HD
    - Windows 7 64 Bit
    - Coldfusion 9 64 Bits
    - Apache 2.2.21

    Does it have any problem in this environment or Router.cfm can not really be directly accessed?

  6. #36
    Sencha Premium Member
    Join Date
    Aug 2012

    Default Is this plugin still good?

    I am fairly new to ExtJs but want to get a better understanding of for CFM use. I downloaded the zip file and followed the instruction but i'm getting a error.
    Uncaught TypeError: Cannot read property 'APIDesc' of undefined
    Can anyone help elaborate on this ?


  7. #37
    Sencha Premium Member
    Join Date
    Feb 2012

    Default I am using Sencha with CF 9. Works FINE

    I tweaked some work that was done with others. Give me your email and I will be happy to zip up a folder with all that you need (including example CFCs). It's Easy-Peasy. Just have to add one file in a resource (assume you are using Architect.)


Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts