Results 1 to 4 of 4

Thread: [FIXED][3.0rc1] GroupTabs Example CSS BUG in IE7

    You found a bug! We've classified it as a bug in our system. We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Ext JS Premium Member oaugustus's Avatar
    Join Date
    May 2007
    Location
    Belo Horizonte, Brazil
    Posts
    66

    Default [FIXED] [3.0rc1] GroupTabs Example CSS BUG in IE7

    Playing with examples in Ext3.0, I find a bug in the CSS example GroupTabs in IE7. See the attached image.
    Noticed that the problem was the following line:
    Code:
    .x-tab-panel.x-grouptabs-panel {
        background-color: #4E78B1;
       padding: 15px;
    }
    . I managed to solve this way
    Code:
    .x-tab-panel.x-grouptabs-panel {
        background-color: #4E78B1;
        /*padding: 15px*/ /*I replace this line */
        border: solid 15px #4E78B1; /* for this*/
    }
    But this would be the best way?
    Attached Images Attached Images
    Otvio Augusto Rodrigues Fernandes
    Net On - Solues Tecnolgicas Ltda
    Desenvolvimento e Consultoria em ExtJS
    www.neton.com.br
    [email protected]
    (31) 3075-7868

  2. #2
    Sencha User mschwartz's Avatar
    Join Date
    Nov 2008
    Location
    San Diego, Peoples' Republic of California
    Posts
    2,061

    Default

    I was going to post a thread about GroupTabs myself.

    I played around with the example over the weekend, and I'd recommend that it be fixed so you can have normal tab panels on the right where the demos have grids.

    The problem ultimately is that GroupTabs extends TabPanel and then does all kinds of nasty things to the CSS for tab panel.

    This prevents you from using a normal TabPanel in the right, or from using GroupTabs in a CardLayout where you switch to another card that has a TabPanel.

  3. #3
    Sencha User
    Join Date
    Mar 2007
    Location
    Haarlem, Netherlands
    Posts
    1,243

    Default

    This is fixed in SVN revision 4454.

  4. #4
    Ext JS Premium Member
    Join Date
    Dec 2008
    Posts
    8

    Default

    Hi,

    i think a bug remain in the latest code from svn (3.0.3).

    I have already post a thread on the premium forum but nobody answer so i hope someone could help me here.

    Link to my previous thread :
    http://www.extjs.com/forum/showthread.php?t=84388

    I have uploaded a live test :
    http://hebergementperso.free.fr/ext-...grouptabs.html

    Some help would be much appreciate.

    Lo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •