Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Inetllij 2020.2 not supported

  1. #21
    Sencha Premium User wemerson.januario's Avatar
    Join Date
    Nov 2008
    Location
    Goiânia - GO, Brazil
    Posts
    905
    Answers
    15

    Default

    This is a known issue we are working on a fix to be released next few weeks.
    Wemerson Januario @JanuarioCoder
    Novanti Tecnologia, Sencha MVP/ Ext JS Consultant
    ____________________________________________
    Hire me on UpWork:

    GitHub
    https://github.com/wemersonjanuario

    Treinamento e Consultoria Ext JS. QUALIFIQUE-SE JÁ!

  2. #22
    Sencha Premium Member
    Join Date
    Jan 2010
    Location
    Vancouver, Canada
    Posts
    261
    Answers
    4

    Default

    They just released a new version, 6.0.14, but it still has the same issue. D'oh!

  3. #23
    Sencha Premium User wemerson.januario's Avatar
    Join Date
    Nov 2008
    Location
    Goiânia - GO, Brazil
    Posts
    905
    Answers
    15

    Default

    Quote Originally Posted by bogc View Post
    They just released a new version, 6.0.14, but it still has the same issue. D'oh!
    Yes, We have released 6.0.14 with this fix.

    What Jetbrains IDE are you using and version?

    And what error you are seeing?

    thanks
    Wemerson Januario @JanuarioCoder
    Novanti Tecnologia, Sencha MVP/ Ext JS Consultant
    ____________________________________________
    Hire me on UpWork:

    GitHub
    https://github.com/wemersonjanuario

    Treinamento e Consultoria Ext JS. QUALIFIQUE-SE JÁ!

  4. #24
    Sencha Premium Member
    Join Date
    Jan 2010
    Location
    Vancouver, Canada
    Posts
    261
    Answers
    4

    Default

    The error that was reported originally on this thread. Follow the thread.

    IntelliJ IDEA 2020.2.3 (Ultimate Edition)
    Build #IU-202.7660.26, built on October 6, 2020
    Runtime version: 11.0.8+10-b944.34 x86_64
    VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
    macOS 10.15.7

    I fixed it by deleting the groovy-2.5.8.jar from the ~/Library/Application Support/JetBrains/IntelliJIdea2020.2/plugins/sencha-jetbrains-plugin/lib folder. You continue to include this version in the distribution (sjp-6.0.14.zip).

  5. #25
    Sencha Premium Member
    Join Date
    Jan 2010
    Location
    Vancouver, Canada
    Posts
    261
    Answers
    4

    Default

    020-11-11 23:40:21,357 [ 1618] ERROR - llij.ide.plugins.PluginManager - IntelliJ IDEA 2020.2.3 Build #IU-202.7660.26
    2020-11-11 23:40:21,357 [ 1618] ERROR - llij.ide.plugins.PluginManager - JDK: 11.0.8; VM: OpenJDK 64-Bit Server VM; Vendor: JetBrains s.r.o.
    2020-11-11 23:40:21,358 [ 1619] ERROR - llij.ide.plugins.PluginManager - OS: Mac OS X
    2020-11-11 23:40:21,358 [ 1619] ERROR - llij.ide.plugins.PluginManager - Plugin to blame: Sencha Ext JS version: 6.0.14.616
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT -
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT - Plugin Error: Plugin 'com.sencha.idea.IdeaPlugin' failed to initialize and will be disabled. Please restart IntelliJ IDEA.
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT -
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT - java.lang.ExceptionInInitializerError
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT - at org.codehaus.groovy.runtime.InvokerHelper.<clinit>(InvokerHelper.java:86)
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT - at groovy.lang.GroovyObjectSupport.getDefaultMetaClass(GroovyObjectSupport.java:59)
    2020-11-11 23:40:21,359 [ 1620] INFO - STDOUT - at groovy.lang.GroovyObjectSupport.<init>(GroovyObjectSupport.java:32)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at groovy.lang.Closure.<init>(Closure.java:211)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at groovy.lang.Closure.<init>(Closure.java:228)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at groovy.lang.Closure$1.<init>(Closure.java:193)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at groovy.lang.Closure.<clinit>(Closure.java:193)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.sencha.idea.LicenseValidator.<init>(LicenseValidator.groovy)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.sencha.idea.LicenseValidator.<clinit>(LicenseValidator.groovy:38)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.lang.Class.forName0(Native Method)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.lang.Class.forName(Class.java:398)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.serviceContainer.ComponentManagerImpl.registerComponent(ComponentManagerImpl.kt:287)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.serviceContainer.ComponentManagerImpl.registerComponents(ComponentManagerImpl.kt:193)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.serviceContainer.ComponentManagerImpl.registerComponents(ComponentManagerImpl.kt:157)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.ApplicationLoader$registerAppComponents$1.apply(ApplicationLoader.kt:102)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.ApplicationLoader$registerAppComponents$1.apply(ApplicationLoader.kt)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture$UniApply.tryFire(CompletableFuture.java:642)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture.complete(CompletableFuture.java:2073)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.ApplicationLoader$initApplication$2.accept(ApplicationLoader.kt:390)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.ApplicationLoader$initApplication$2.accept(ApplicationLoader.kt)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:859)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture.uniWhenCompleteStage(CompletableFuture.java:883)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture.whenComplete(CompletableFuture.java:2251)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.util.concurrent.CompletableFuture.whenComplete(CompletableFuture.java:143)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.ApplicationLoader.initApplication(ApplicationLoader.kt:387)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.a.a(a.java:106)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.ide.a.i.ar.a(ar.java:91)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.ide.a.i.I.b(I.java:276)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.ide.a.i.J.b(J.java:307)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.ide.a.i.J.c(J.java:167)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.ide.a.i.J.a(J.java:79)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.MainImpl.start(MainImpl.java:98)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.StartupUtil.startApp(StartupUtil.java:302)
    2020-11-11 23:40:21,360 [ 1621] INFO - STDOUT - at com.intellij.idea.StartupUtil.prepareApp(StartupUtil.java:242)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at com.intellij.ide.plugins.MainRunner.lambda$start$0(MainRunner.java:47)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at java.base/java.lang.Thread.run(Thread.java:834)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - Caused by: groovy.lang.GroovyRuntimeException: Conflicting module versions. Module [groovy-xml is loaded in version 2.5.8 and you are trying to load version 2.5.11
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl$DefaultModuleListener.onModule(MetaClassRegistryImpl.java:524)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromProperties(ExtensionModuleScanner.java:87)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromMetaInf(ExtensionModuleScanner.java:81)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanClasspathModulesFrom(ExtensionModuleScanner.java:63)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanClasspathModules(ExtensionModuleScanner.java:54)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:125)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:86)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - at groovy.lang.GroovySystem.<clinit>(GroovySystem.java:36)
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT - ... 45 more
    2020-11-11 23:40:21,361 [ 1622] INFO - STDOUT -
    2020-11-11 23:40:37,842 [ 18103] INFO - #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------

  6. #26
    Sencha Premium User cesarzea's Avatar
    Join Date
    Nov 2007
    Location
    Madrid, Spain
    Posts
    21

    Default

    I have the same problem.
    -------------------------------------
    SQL Server expert consultant.
    ExtJS developer from ExtJS 1.0 version to now.
    Java developer.


    Working as freelance and in my own company from 1.999
    https://www.linkedin.com/in/cesarzea/
    www.jaunesistemas.com

  7. #27
    Sencha Premium User wemerson.januario's Avatar
    Join Date
    Nov 2008
    Location
    Goiânia - GO, Brazil
    Posts
    905
    Answers
    15

    Default

    We have fixed this issue. please download again from support portal. Thanks
    Wemerson Januario @JanuarioCoder
    Novanti Tecnologia, Sencha MVP/ Ext JS Consultant
    ____________________________________________
    Hire me on UpWork:

    GitHub
    https://github.com/wemersonjanuario

    Treinamento e Consultoria Ext JS. QUALIFIQUE-SE JÁ!

  8. #28
    Sencha Premium Member
    Join Date
    Jul 2014
    Location
    Gilbert, AZ
    Posts
    12

    Default

    Quote Originally Posted by russ396 View Post
    Based on Windows hack listed above, I did the same for Ubuntu. On Ubuntu 18.04 with Jetbrains Toolbox, and running IntelliJ IDEA Ultimate 2020.2, the libraries are found under ~/.local/share/JetBrains/IntelliJIdea2020.2/sencha-jetbrains-plugin/lib. Deleting groovy-2.5.8.jar, groovy-json-2.5.8.jar and groovy-xml-2.5.8.jar seems to work. I did the following to get the plugin working:

    rm -f ~/.local/share/JetBrains/IntelliJIdea2020.2/sencha-jetbrains-plugin/lib/groovy*2.5.8.jar
    Start IntelliJ IDEA Ultimate 2020.2
    Enable plugin
    Restart IntelliJ IDEA Ultimate 2020.2

    Everything seems to work as expected for me. Sencha JetBrains Plugin regression testing and production release would be a much better solution.
    Same issue with Jetbrains Plugin 6.0.14 on Ubuntu 20.04LTS/IntelliJ IDEA 2020.2.3 (Ultimate Edition) Build #IU-202.7660.26. Fix is the same as listed above. Note that Jetbrains Plugin 6.0.14 is not on the Jetbrains Marketplace yet, so I did an install from zip file.

  9. #29
    Sencha Premium Member
    Join Date
    Jul 2014
    Location
    Gilbert, AZ
    Posts
    12

    Default

    Quote Originally Posted by russ396 View Post
    Same issue with Jetbrains Plugin 6.0.14 on Ubuntu 20.04LTS/IntelliJ IDEA 2020.2.3 (Ultimate Edition) Build #IU-202.7660.26. Fix is the same as listed above. Note that Jetbrains Plugin 6.0.14 is not on the Jetbrains Marketplace yet, so I did an install from zip file.
    This was fixed with the 6.0.14.621 Jetbrains Plugin dated Nov 17, 2020 and works as expected with above environment. The older version 6.0.14.616 does not work. Thanks for the fix!

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •