Results 1 to 5 of 5

Thread: What is the highest supported version of chrome-driver

  1. #1
    Sencha Premium Member
    Join Date
    Nov 2013
    Posts
    36

    Default What is the highest supported version of chrome-driver

    I've experimented a bit, but in my environment I can not use chromedriver higher than v 2.43. Can you confirm this, and if so, can we expect that this will be fixed, so we can use a recent version. Version 2.43 uses chrome v.70, which is of course 10 versions old.

    Thanks

  2. #2
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    London, England
    Posts
    396
    Answers
    75

    Default

    Sencha Test does work with newer ChromeDriver versions. ChromeDriver changed the versioning number format after 2.46, and instead released ChromeDriver version numbers that matched the equivalent Chrome version number, for example Chrome 81 requires ChromeDriver 81.

    Sencha Test 2.3.0 (GA) included ChromeDrivers 74 through 77 for the Embedded Selenium Server, and the last nightly build of Sencha Test included ChromeDrivers 74 through 79.

    If you need to use a specific version of ChromeDriver that isn't mentioned above then you can download the required ChromeDriver version from here, and setup your own Standalone Selenium Server per the documentation and use that instead of the Embedded Selenium Server.
    Daniel Gallo

  3. #3
    Sencha Premium Member
    Join Date
    Nov 2013
    Posts
    36

    Default

    tried this with node v7.10.1 and node v8.17.0

    use chromedriver 79.0.3945.36 by running
    Code:
    selenium-standalone start --drivers.chrome.version=79.0.3945.36 --drivers.chrome.baseURL=https://chromedriver.storage.googleapis.com
    as is explained here

    then the following error message
    Code:
    [ERROR] [model/browser/SandboxBrowser-10] [ERROR] [orion] Error: A new session could not be created.
        at url("http://my-url-to-test") - C:\Program Files\Sencha\Test\2_3_0_328\stc\node_modules\@sencha\orion-core\serve\context\WebDriver.js:148:10
        at timeouts("script", 10000) - C:\Program Files\Sencha\Test\2_3_0_328\stc\node_modules\@sencha\orion-core\serve\context\WebDriver.js:141:29
        at init() - C:\Program Files\Sencha\Test\2_3_0_328\stc\node_modules\@sencha\orion-core\serve\context\WebDriver.js:122:10
    however, when running
    Code:
    selenium-standalone start
    and effectively using the 2.43 chromedriver, everything is working nicely. I can not figure out what is going wrong here.

  4. #4
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    London, England
    Posts
    396
    Answers
    75

    Default

    I normally just download the Selenium Server 3.9.1 .jar file directly, and run that manually to start the server, e.g.

    Code:
    java -jar selenium-server-standalone-3.9.1.jar
    As long as the ChromeDriver executable is in the same folder as the .jar, it sees and uses it when Chrome is required.
    Daniel Gallo

  5. #5
    Sencha Premium Member
    Join Date
    Nov 2013
    Posts
    36

    Default

    did exactly as you described and get same error message


    • Sencha Test v2.3.0.328
    • chromedriver 79.0.3945.36
    • selenium-server-standalone-3.141.59.jar

    also for good measure used selenium-server-standalone-3.9.1.jar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •