Results 1 to 6 of 6

Thread: Architect on Ubuntu 20.04 : Pango ERROR, Harfbuzz version too old (1.3.1)

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium Member
    Join Date
    May 2011
    Posts
    8

    Default Architect on Ubuntu 20.04 : Pango ERROR, Harfbuzz version too old (1.3.1)

    Hi,

    I just updated my Ubuntu to 20.04 LTS, and i get a error when starting Sencha Architect :

    Code:
    $ SenchaArchitect 
    (SenchaArchitect:46473): Pango-ERROR **: 11:06:09.273: Harfbuzz version too old (1.3.1)
    
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 20.04 LTS
    Release:    20.04
    Codename:    focal
    Electron, used in Architect, is too old for Ubuntu 20.
    The only solution seems to downgrade Pango (used in electron) to an older release but 1.44.7 (lastest) is the only version available on Ubuntu 20

    More info here : https://github.com/electron/electron/issues/20348

    $ sudo apt policy libpango-1.0-0
    Code:
    libpango-1.0-0:
      Installé : 1.44.7-2ubuntu4
      Candidat : 1.44.7-2ubuntu4
     Table de version :
     *** 1.44.7-2ubuntu4 500
            500 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 Packages
            100 /var/lib/dpkg/status
    How can i downgrade safely pango ? Have you another solution ?



  2. #2

    Default

    Same here on Debian Sid

    % /opt/sencha/architect/4.2/SenchaArchitect
    Gtk-Message: 12:02:14.579: Failed to load module "gail"
    Gtk-Message: 12:02:14.579: Failed to load module "atk-bridge"


    (SenchaArchitect:240911): Pango-ERROR **: 12:02:16.135: Harfbuzz version too old (1.3.1)



    % sudo apt policy libpango-1.0-0

    libpango-1.0-0:
    Installed: 1.44.7-4
    Candidate: 1.44.7-4
    Version table:
    *** 1.44.7-4 500
    500 http://deb.debian.org/debian sid/main amd64 Packages
    100 /var/lib/dpkg/status

  3. #3

    Default

    Same issue in Ubuntu 20.04 LTS.

    I found a solution on Stack Exchange that not needs to downgrade pango libs but didn't tried because it's too tricky for just trying the trial version of Sencha Architect: https://unix.stackexchange.com/quest...ersion-too-old

    Hope this helps

  4. #4

    Default

    Quote Originally Posted by pascal_chronotech View Post
    Hi,

    I just updated my Ubuntu to 20.04 LTS, and i get a error when starting Sencha Architect :

    Code:
    $ SenchaArchitect 
    (SenchaArchitect:46473): Pango-ERROR **: 11:06:09.273: Harfbuzz version too old (1.3.1)
    
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 20.04 LTS
    Release:    20.04
    Codename:    focal
    Electron, used in Architect, is too old for Ubuntu 20.
    The only solution seems to downgrade Pango (used in electron) to an older release but 1.44.7 (lastest) is the only version available on Ubuntu 20

    More info here : https://github.com/electron/electron/issues/20348

    $ sudo apt policy libpango-1.0-0
    Code:
    libpango-1.0-0:
      Installé : 1.44.7-2ubuntu4
      Candidat : 1.44.7-2ubuntu4
     Table de version :
     *** 1.44.7-2ubuntu4 500
            500 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 Packages
            100 /var/lib/dpkg/status
    How can i downgrade safely pango ? Have you another solution ?


    Same issue in Ubuntu 20.04 LTS.

    I found a solution on Stack Exchange that not needs to downgrade pango libs but didn't tried because it's too tricky for just trying the trial version of Sencha Architect:
    https://unix.stackexchange.com/quest...ersion-too-old

    Hope this help

  5. #5
    Sencha Premium User
    Join Date
    Apr 2009
    Location
    Raalte, Netherlands
    Posts
    253

    Default

    Are there any updates on this? I think it is unacceptable that this error makes it for Ubuntu users impossible to make use of licensed software like Sencha Themer and Architect. This problem exists already for a while and no one at Sencha seems to read this forums urgencies. I have a VmWare Player installed only to have a workaround for this problem. It is not how it is supposed to be.

    Sencha developer team, do something about this please.

  6. #6
    Sencha Premium Member erick.rosales@copamex.com's Avatar
    Join Date
    Jan 2016
    Location
    Mexico
    Posts
    5

    Exclamation The error persist in 2021

    The error persist in 2021. How can I fix it in Ubuntu 20?

    I want to test Sencha Architect in Linux in order to see if it improves its performance because in Windows it is really slow with big projects.

    ~/sencha/Sencha Architect 4.2$ ./SenchaArchitect


    (SenchaArchitect:1642): Pango-ERROR **: 18:09:30.516: Harfbuzz version too old (1.3.1)


    «trap» para punto de parada/seguimiento (`core' generado)
    [email protected]:~/sencha/Sencha Architect 4.2$ ./SenchaArchitect --disable-gpu


    (SenchaArchitect:1655): Pango-ERROR **: 18:09:51.703: Harfbuzz version too old (1.3.1)


    «trap» para punto de parada/seguimiento (`core' generado)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •