Hello, Help, Anyone?

On an application that is used across several timezones and with different regional settings, some users are reporting an issue I was unable to replicate.
With extra logging, the origin was detected to be in calling of https://docs.sencha.com/extjs/7.1.0/...hod-loadRecord. Any ideas of what it could be and how to troubleshoot the issue?

I cannot share code, but the view structure being loaded is the following:
Code:
items: [
  {
   xtype: 'form',
   itemId: 'MailContentForm',
   ...,
   items: [
    {
     xtype: 'container',
     ...,
     items: [
      {
       xtype: 'container',
       ...
       items: [
        {
         xtype: 'container',
         layout: 'hbox',
         items: [
          {
           xtype: 'textfield',
           ...
          },
          {
           xtype: 'checkboxfield',
           ...
          }
         ]
        },
        ...
       ]
      },
      {
       xtype: 'container',
       ...
       items: [
        {
         xtype: 'fieldset',
         ...,
         items: [
          {
           xtype: 'textfield',
           ...,
           listeners: {
            change: {
             ...
            }
           }
          },
          ...
         ]
        }
       ]
      }
     ]
    },
    {
     xtype: 'textfield',
     ...
    },
    {
     xtype: 'textareafield',
     ...
    }
   ]
  }
 ]
}
Notice that it works on most users so i kind of having hard time replicating the issue so i can try troubleshooting it.


Thanks in advance,
João