Results 1 to 4 of 4

Thread: Sencha Architect for macOS Catalina (10.15)

  1. #1

    Default Sencha Architect for macOS Catalina (10.15)

    After upgrading my mac to Catalina, Sencha Architect (i tried version 3 and 4) stopped opening completely. Can anyone confirm it is supported for Catalina?

  2. #2
    Ext JS Premium Member tangix's Avatar
    Join Date
    Mar 2010
    Stockholm, Sweden


    Don't know if this helps or not. I am running Sencha Architect 4.2.6 build 425 on Catalina 10.15.2 BUT with the caveat that installed Sencha Architect on a brand new computer already running Catalina - i.e. no upgrade.

  3. #3



    I have a similar problem with Sencha Cmd. After I upgraded to MacOS Catalina 10.15.2, MacOS doesn't see it as installed. When I run sencha command on the terminal, it returns command not found. I reinstalled SenchaCmd- but it didn't have any effect. Were you able to manage to Sencha Architect work?

  4. #4


    Not that I understand a lot about OS internals, I have read that with MacOS Catalina, the default shell became zsh. One site was advising to copy the contents of the existing '.bash_profile' into a new '~/.zshrc' file and fortunately it worked!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts