Results 1 to 2 of 2

Thread: Unable to remove Ext-Watermark

  1. #1
    Sencha Premium User
    Join Date
    Oct 2018

    Default Unable to remove Ext-Watermark

    I have inherited an ExtJs project that I am working on upgrading to the latest framework. It is a simple 5.1.0 application with just dependencies on the charts package, and a very small custom package to handle our Data Layer(Authentication, JSON tokens etc...). There is about 5 views and a fixed Hierarchy menu on the left side of the screen, to be honest there is more logic in building the hierarchy tree then anywhere else.
    So far the project has been very easy to upgrade, until I tried to get rid of the watermark. In the upper right hand corner of all of the title bars there is a lower case d , I was able to edit the code in the .scss file within the Ext-Watermark source code folder to remove all references to it for the vast majority of the application, but the title eludes me.

    Other things that are not looking to Kosher:
    When I run the command sencha framework list I get the following responce:
    Available frameworks

    - ext: (Trial)
    - Framework: Ext JS
    - Version:
    - Path: ext
    - Not in use by any of the applications listed on workspace.json.
    This product is licensed commercially for a limited period for evaluation.

    The version of the SDK I have been using to upgrade the application is version
    -ext Version:

    The way that I was forced to upgrade the application was to generate a new application(a classic, a universal, and a modern) and then move the code for the application into the newly generated app by hand. This was suggested to me by a Sencha tech after they were unable to help me upgrade via the proper way(Using the CLI).
    The command I used to generate the application is:
    sencha -sdk "C:\Sencha\SDKs\new_ext-6.7.0\ext-6.7.0\" generate app -modern eCoachModern ./eCoachModernApp

    At first we were using a trial, but have paid for the license years ago, and have upgraded legitimately each time since initial purchase, s0 now I am unable to complete the upgrade becuase I cannot get rid of this watermark. I can find where it is being inserted and comment it out I'm sure, but I am also sure this this will cause problems if not fixed properly.

    Also I am unable to generate applications all of a sudden, when I run the command I pasted in above I am left with a file in the target location called SENCHA.REDIECT this redifile is and whay I can't generate anything any longer, I would greatly appreciate that as well


    current application:
    ExtJs 5.1.0
    Current version of CMD
    Current version for Framework(so the app thinks)
    Actual Current version of FW

  2. #2
    Sencha - Forum Administrator
    Join Date
    Sep 2017


    Thank you so much for your post. I apologize for the delay. I have shared this with the support staff and someone will get back to provide assistance as soon as possible. Your patience is greatly appreciated!

    Kind Regards,


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts