Results 1 to 3 of 3

Thread: Imposible to use version 6.6.0

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Jun 2018

    Default Imposible to use version 6.6.0

    I've been months trying to install new version of sencha and it's imposible. I've tried this things:

    1. Upgrade my actual project with new packages as written here:
    but I was not able because I couldn't make my webpackconfig works. So I tried to run one of your examples. I faced this problem: A problem 404 with my account that finally you managed to fix.
    2. After that I tried to install npm install -g @sencha/ext-react-gen but it sais:
    i [ext]: activate: @sencha/ext-classic v6.6.0.258 installed
      return, stringToFlags(flags), mode);
    Error: EACCES: permission denied, open './package.json'
        at Object.fs.openSync (fs.js:646:18)
        at Object.fs.writeFileSync (fs.js:1299:33)
        at Object.<anonymous> (/usr/local/lib/node_modules/@sencha/ext-react-gen/node_modules/@sencha/ext-classic/activate.js:27:4)
        at Module._compile (module.js:652:30)
        at Object.Module._extensions..js (module.js:663:10)
        at Module.load (module.js:565:32)
        at tryModuleLoad (module.js:505:12)
        at Function.Module._load (module.js:497:3)
        at Function.Module.runMain (module.js:693:10)
        at startup (bootstrap_node.js:191:16)
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! @sencha/[email protected] install: `node activate.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the @sencha/[email protected] install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    npm ERR! A complete log of this run can be found in:
    3. Soooo I tried downloading your examples from github:
    git clone
    Then I tried npm install in the root folder as expecified. And it gave me the error:

    lerna notice cli v3.4.3
    lerna info Bootstrapping 20 packages
    lerna info Installing external dependencies
    lerna ERR! npm install exited 1 in '@sencha/ext-react-modern-demo'
    lerna ERR! npm install stderr:
    npm ERR! code E403
    npm ERR! 403 Forbidden: @sencha/[email protected]~6.6.0
    npm ERR! A complete log of this run can be found in:
    I supose I don't aquistated that plugin. So I

    4. Went to ext-react-modern-boilerplate folder and run npm install. It worked. Then I tried npm start. Error:

    log @ ext.js:8523
    react-reconciler.development.js:59 Uncaught Error: Expected subtree parent to be a mounted class component. This error is likely caused by a bug in React. Please file an issue.
        at invariant (react-reconciler.development.js:52)
        at findCurrentUnmaskedContext (react-reconciler.development.js:1484)
        at getContextForSubtree (react-reconciler.development.js:9845)
        at updateContainerAtExpirationTime (react-reconciler.development.js:9902)
        at Object.updateContainer (react-reconciler.development.js:9936)
        at ProxyComponent.componentDidMount (ExtJSComponent.js:57)
        at ProxyComponent.componentDidMount (react-hot-loader.development.js:577)
        at commitLifeCycles (react-dom.development.js:15961)
        at commitAllLifeCycles (react-dom.development.js:17262)
        at HTMLUnknownElement.callCallback (react-dom.development.js:149)
    So I gaved up. The next thing to try was:
    5. I installed a new react application with create-app-react command. Then I followed the steps written in I have the error now of: Ext is not defined The thing that surpridsed me is that the folder with the compiled code of sencha it's not being created. I did exactily what the guide says. I even wrote:

    new ExtReactWebpackPlugin({
       port: port,
       output: "sencha-react"
    To check if sencha-react was created. But it is not.

    What could I do to make things works? I tried everything.

  2. #2
    Sencha - Forum Administrator
    Join Date
    Sep 2017


    I am sorry for the trouble and unfortunately I cannot provide you answer. I have, however, passed this issue on to the support team and have asked that they get back to you as soon as possible to provide some assistance. I appreciate your patience.


  3. #3
    Sencha User
    Join Date
    Jun 2018


    I have already a ticket open since I had 403 issues that I wrote in the first place (it is solved but it is not solved the problem of upgrade) but is not as detailed as this post. The issue is #45052

Similar Threads

  1. Replies: 0
    Last Post: 2 Mar 2018, 10:11 AM
  2. SA 3.5 EA Its imposible to compile a project
    By aestevez in forum Sencha Architect 3.x: Q&A
    Replies: 7
    Last Post: 26 Feb 2016, 10:00 AM
  3. Replies: 2
    Last Post: 15 Aug 2013, 1:57 PM
  4. Replies: 2
    Last Post: 4 Mar 2013, 11:21 AM
  5. Sencha Build: Production version causes error, Testing version works fine
    By parky128 in forum Sencha Touch 2.x: Discussion
    Replies: 10
    Last Post: 18 Feb 2013, 3:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts