Results 1 to 2 of 2

Thread: CMD generates broken apps

  1. #1

    Default CMD generates broken apps

    Hi, I've recently tried to scaffold a new app and have encountered numerous issues.

    Firstly, Cmd used to scaffold out an app directory with a main view, model, store, viewModel, viewController etc. Now it doesn't even scaffold an app directory.
    EDIT: Okay, seems that I'm best to use `sencha generate app` instead of the instructions provided on the Getting Started page.

    I tried creating a new app via `sencha app init [email protected] --modern MyApp` and this works fine (still no app folder though, just a messagebox app). However, when i run this in the browser, I see console errors related to Fashion etc.

    If I scaffold via `sencha app init [email protected] --classic MyApp` the generated app doesn't even run correctly in the browser (crashes as it can't find the messagebox class).

    Even scaffolding using the open-tooling generates a broken app - follow the docs, then shrink your browser down to phone size and reload - you'll see that it cannot find `phone.json`.

    Please advise.

  2. #2
    Sencha - Forum Administrator
    Join Date
    Sep 2017


    Thank you for your question. I have shared this post with the support staff and asked them to look into this at their earliest convenience. Thank you for your patience!


Similar Threads

  1. sencha cmd broken - can't generate workspace apps
    By zokeefe in forum Sencha Ext JS Q&A
    Replies: 3
    Last Post: 27 Apr 2015, 1:35 PM
  2. [FIXED] CMD5 app build broken with new and existing apps
    By bhutten in forum Ext 5: Bugs
    Replies: 11
    Last Post: 10 Sep 2014, 12:41 PM
  3. [OPEN] [2.3.1a] iOS 7 home screen apps still losing status bar for production apps
    By Steffen Hiller in forum Sencha Touch 2.x: Bugs
    Replies: 2
    Last Post: 8 May 2014, 1:23 PM
  4. Replies: 14
    Last Post: 21 Aug 2013, 12:52 PM
  5. [FIXED] Example Apps and Images are broken on GPL 2.0.0 release
    By elwhiz in forum Sencha Touch 2.x: Bugs
    Replies: 13
    Last Post: 28 Mar 2012, 4:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts