Results 1 to 7 of 7

Thread: BadgeText doesn't render correctly

  1. #1
    Sencha User
    Join Date
    Nov 2016
    Posts
    26
    Answers
    2

    Default BadgeText doesn't render correctly

    Hello. I use MaterialTheme and Modern toolkit. Have a problem with tabs BadgeText, can see only half of badge (like in the screenshot). How can I solve it? Thanks.

    Screenshot_53.jpg

  2. #2
    Sencha User
    Join Date
    Mar 2009
    Location
    München
    Posts
    574
    Answers
    99

    Default

    You can create fiddle sample for us.

  3. #3

  4. #4
    Sencha User
    Join Date
    Mar 2009
    Location
    München
    Posts
    574
    Answers
    99

    Default

    Add the following css fix to your theme file:

    Code:
    .x-docked-top .x-has-badge .x-badge-el {
        top: 0px;
    }

  5. #5
    Sencha User
    Join Date
    Nov 2016
    Posts
    26
    Answers
    2

    Default

    Quote Originally Posted by yeghikyan View Post
    Add the following css fix to your theme file:

    Code:
    .x-docked-top .x-has-badge .x-badge-el {
        top: 0px;
    }
    Thanks, I understood, that I can make top: 0px;, but how to make it be over the background, to see it full with top: 8px;? Tried to make z-index, didn't help.

  6. #6
    Sencha User
    Join Date
    Mar 2009
    Location
    München
    Posts
    574
    Answers
    99

    Default

    Ok, I have no idea why have you located a panel in toolbar. I have fixed your your sample.


  7. #7
    Sencha User
    Join Date
    Mar 2009
    Location
    München
    Posts
    574
    Answers
    99

    Default

    What I have also noticed, your GUI is a little bit overnested. You do not need to put a container in the tab panel and inside the container put the grid panel etc.

Similar Threads

  1. Grid doesn't render data correctly
    By TheWorldNode in forum Ext JS 6.x Q&A
    Replies: 9
    Last Post: 14 Feb 2018, 3:39 AM
  2. [CLOSED] [v 4.1.0] Grid header doesn't render correctly
    By lutiayi in forum Ext:Bugs
    Replies: 1
    Last Post: 4 Dec 2012, 7:39 AM
  3. is this a bug? Ext.Map doesn't render correctly after initial run.
    By djd in forum Sencha Touch 1.x: Discussion
    Replies: 0
    Last Post: 8 Feb 2011, 7:36 AM
  4. combo doesn't render values correctly
    By Ivan2010 in forum Ext 2.x: Help & Discussion
    Replies: 5
    Last Post: 16 Jul 2009, 9:26 PM
  5. [2.0.1] Grid doesn't show correctly on first render
    By thiagoaos in forum Ext 2.x: Help & Discussion
    Replies: 3
    Last Post: 20 May 2008, 9:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •