Results 1 to 6 of 6

Thread: C2008: Requirement had no matching files (Ext.Toast)

  1. #1
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    90
    Answers
    3

    Default C2008: Requirement had no matching files (Ext.Toast)

    Hi,
    in one of my controllers I am using Ext.toast which fails in a compiled version (Ext.toast is not a function). When I add the following in that controller:
    Code:
        requires: [//
            'Ext.Toast'
        ],
    I then get the above error from CMD (C2008: Requirement had no matching files (Ext.Toast)). I am using 6.5.3.

    How can that be fixed?
    Thanks

  2. #2
    Sencha - Support Team bjdurham85's Avatar
    Join Date
    Mar 2014
    Posts
    962
    Answers
    55

    Default

    Hi--,

    Is this for modern, classic or both?

    Bryan

  3. #3
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    90
    Answers
    3

    Default

    AT the moment for Classic.

  4. #4
    Sencha - Support Team bjdurham85's Avatar
    Join Date
    Mar 2014
    Posts
    962
    Answers
    55

    Default

    Not sure if using an IDE + Plugin (and it missed it) but can you try changing that to the following and let me know if it helps?

    Ext.window.Toast?


    Bryan

  5. #5
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    90
    Answers
    3

    Default

    Hi Bryan,
    sorry, I should have mentioned that I had tested that as well. Same result: [ERR] C2008: Requirement had no matching files (Ext.window.Toast).

    And: no IDE or Plugin.
    Thanks ok

  6. #6
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,379
    Answers
    3997

    Default

    What version of Sencha Cmd are you using? I just ran a test with Ext JS 6.5.3.57 and Sencha Cmd 6.5.3.6 and requiring Ext.window.Toast works no problems for me (Ext.Toast failed as expected).
    Mitchell Simoens @LikelyMitch

    Check out my GitHub:
    https://github.com/mitchellsimoens

    Posts are my own, not any current, past or future employer's.

Similar Threads

  1. [ERR] C2008: Requirement had no matching files
    By idealer in forum Ext: Q&A
    Replies: 3
    Last Post: 24 Aug 2017, 12:25 PM
  2. Replies: 1
    Last Post: 25 Jun 2017, 10:36 PM
  3. Replies: 8
    Last Post: 1 Jun 2016, 4:00 AM
  4. [ERR] C2008: Requirement had no matching files (Ext.grid.Grid)
    By Bramaram Naik Nenavath in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 6 Jan 2016, 12:20 PM
  5. From extjs 5 to Universal App : Requirement had no matching files
    By stewardsencha in forum Sencha Ext JS Q&A
    Replies: 3
    Last Post: 5 Jan 2016, 7:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •