Results 1 to 4 of 4

Thread: Ext6.5.2 Modern: ComboBox with edge picker fails on first expand

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium User wemerson.januario's Avatar
    Join Date
    Nov 2008
    Location
    Goiânia - GO, Brazil
    Posts
    902

    Default Ext6.5.2 Modern: ComboBox with edge picker fails on first expand

    ComboBox with edge picker fails on first expand after upgrade to Ext JS 6.5.2.

    Combobox picker option changed to floated on Ext 6.5.2, when you change picker config to edge or auto, it fails on first expand.

    the updatePicker method is broken if edge picker especified.


    Uncaught TypeError: picker.getSelectable is not a function
    at constructor.updatePicker (ComboBox.js?_dc=1507747908276:690)
    at constructor.setter [as setPicker] (Config.js?_dc=1507747908270:298)
    at constructor.<anonymous> (Config.js?_dc=1507747908270:265)
    at constructor.doFilter (ComboBox.js?_dc=1507747908276:494)
    at constructor.onExpandTap (ComboBox.js?_dc=1507747908276:386)
    at Object.callback (Util.js?_dc=1507747908270:148)
    at constructor.onClick (Trigger.js?_dc=1507747908275:121)
    at constructor.fire (Event.js?_dc=1507747908272:481)
    at constructor.fire (Dom.js?_dc=1507747908272:459)
    at constructor.publish (Dom.js?_dc=1507747908272:413)



    Here is the fiddle

    https://fiddle.sencha.com/#view/editor&fiddle/287e
    Wemerson Januario @JanuarioCoder
    Novanti Tecnologia, Sencha MVP/ Ext JS Consultant
    ____________________________________________
    Hire me on UpWork:

    GitHub
    https://github.com/wemersonjanuario

    Treinamento e Consultoria Ext JS. QUALIFIQUE-SE JÁ!

  2. #2
    Sencha User Animal's Avatar
    Join Date
    Mar 2007
    Location
    Bédoin/Nottingham
    Posts
    30,890

    Default

    Edge is not really a possibility for a combobox, it needs to float as normal. The keyboard appears at the bottom of the screen.

  3. #3
    Sencha User Animal's Avatar
    Join Date
    Mar 2007
    Location
    Bédoin/Nottingham
    Posts
    30,890

    Default

    If you don't need the "filter as you type" functionality of combobox, use its superclass, "SelectField" instead.

    https://fiddle.sencha.com/#view/editor&fiddle/287k

    Obviously it should not throw an error, so somebody needs to fix it.

  4. #4
    Sencha Premium User wemerson.januario's Avatar
    Join Date
    Nov 2008
    Location
    Goiânia - GO, Brazil
    Posts
    902

    Default

    On Ext 6.5.1 it used to work and after Ext 6.5.3 upgrade I didn't pay attention on this change.

    Thank you Animal for your help and explanation.
    Wemerson Januario @JanuarioCoder
    Novanti Tecnologia, Sencha MVP/ Ext JS Consultant
    ____________________________________________
    Hire me on UpWork:

    GitHub
    https://github.com/wemersonjanuario

    Treinamento e Consultoria Ext JS. QUALIFIQUE-SE JÁ!

Similar Threads

  1. Replies: 5
    Last Post: 11 Oct 2017, 1:23 AM
  2. Replies: 2
    Last Post: 9 Oct 2017, 12:35 AM
  3. [OPEN] Defect w/UUID's and LocalStorage proxy on Modern Ext6
    By FBNitro in forum Ext JS 6.x Bugs
    Replies: 4
    Last Post: 9 Aug 2017, 1:21 AM
  4. Replies: 3
    Last Post: 10 Jul 2017, 11:17 AM
  5. [FNR-28][2.1.1] ComboBox fails to expand in certain cases
    By Jose Jeria in forum Ext GWT: Bugs (2.x)
    Replies: 2
    Last Post: 15 Mar 2010, 6:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •