Results 1 to 5 of 5

Thread: windows sample fails 6.5.0.180

  1. #1
    Ext JS Premium Member
    Join Date
    Apr 2008
    Posts
    2

    Default windows sample fails 6.5.0.180

    I can't get the cmd sample to work.

    I downloaded 64-bit windows cmd (6.5.0.180) and extjs 6.5.0
    I performed the following steps from the documentation.

    C:\>sencha -sdk c:\sencha\ext-6.5.0 generate app MyApp c:\code\sencha
    Sencha Cmd v6.5.0.180
    [INF] Copying framework to c:\code\sencha\ext


    C:\>cd \code\sencha

    C:\code\sencha>sencha app watch
    Sencha Cmd v6.5.0.180
    [INF] Processing Build Descriptor : classic (development environment)
    [ERR] Cannot satisfy requirements for "classic"!
    [ERR] The following versions cannot be satisfied:
    [ERR] MyApp: classic (No matches!)
    [ERR] Cannot satisfy requirements for "theme-triton"!
    [ERR] The following versions cannot be satisfied:
    [ERR] MyApp: theme-triton (No matches!)
    [ERR] Cannot satisfy requirements for "font-awesome"!
    [ERR] The following versions cannot be satisfied:
    [ERR] MyApp: font-awesome (No matches!)
    [ERR] Cannot resolve package requirements

    Platform is windows 7 (64-bit)
    C:\code\sencha>java -version
    java version "1.8.0_112"
    Java(TM) SE Runtime Environment (build 1.8.0_112-b15)
    Java HotSpot(TM) 64-Bit Server VM (build 25.112-b15, mixed mode)


    Any ideas? Same sequence on a Mac (OS X Yosemite 10.10.5) works as documented

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Are you using a workspace? Is c:\code\sencha a directory?

  3. #3
    Ext JS Premium Member
    Join Date
    Apr 2008
    Posts
    2

    Default

    Yes c:\code\sencha is a directory that I'm attempting to generate an app into.

  4. #4
    Ext JS Premium Member
    Join Date
    May 2011
    Posts
    13

    Default

    I'm having the same issue. Using Sencha Cmd (6.5.0.180), I created a workspace using the 6.5.0 sdk. I then created a package in that workspace, but when I attempt to build the package (with no code, just empty shell), I get error "Cannot satisfy requirements for "classic".

  5. #5
    Sencha User
    Join Date
    Apr 2014
    Posts
    110

    Default

    Same problem here... Is it fixed yet?

Similar Threads

  1. Replies: 3
    Last Post: 5 Apr 2017, 8:20 AM
  2. Practical Ext JS 4 sample fails
    By brotherbill in forum Ext 5: Q&A
    Replies: 1
    Last Post: 25 Jun 2014, 7:11 AM
  3. Need Sencha Touch Sample Project using Phonegap for Windows Phone 8
    By santhoshinit in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 13 May 2014, 3:39 PM
  4. Replies: 4
    Last Post: 27 Jan 2013, 7:58 AM
  5. The contact MVC sample fails on Android
    By arvander in forum Sencha Touch 1.x: Bugs
    Replies: 1
    Last Post: 2 Feb 2012, 12:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •