I'm trying to upgrade a workspace and all of its apps from version to version

The workspace builds correctly in and a copy of it is located here:


Under this is ext/, myApp/, packages/, etc.

The ext sdk is located here:


Under this is packages/, sass/, templates/, etc.

My Sencha Cmd path:


Based on the documentation I should be able to do this:

cd ~/Documents/migration/
./~/Applications/Sencha/Cmd/sencha.exe workspace upgrade ~/Documents/archive/ext-6.2.1/

But I get this output:

Sencha Cmd v6.2.1.29
[ERR] Command must be run from a workspace folder

I have also tried replacing workspace with app and running in the workspace and app directories, same error message, although for app it might output the following before the error message:

[INF] Loading configuration for framework directory: ~/Documents/archive/ext-6.2.1

I'm 100% sure the command is being run from a workspace. If there were better diagnostics, I might be able to figure out what is going on.

Can anyone advise?

Thank you.