Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: SenchaCmd 6.5 How to disable slicer?

  1. #1
    Sencha Premium Member
    Join Date
    May 2015
    Posts
    14

    Default Answered: SenchaCmd 6.5 How to disable slicer?

    We just upgraded our projects from 6.2.1 to 6.5.0, and came across some minor issues.

    Apparently the .sencha folder is no longer required and even automatically emptied because of the upgrade. We used to disable the slicer by putting skip.slice=1 in the build.properties file in that folder, but this is no longer possible.

    After a few hours searching and trying alternatives we came up with putting the line "slicer": null, in the app.json or package.json. This works but just does not 'feel right'.

    Two questions:
    1. What is the official method for disabling the slicer for SenchaCmd/ExtJS 6.5?
    2. Where can we find documentation on all options in the app.json?

    Regards,
    Martin

  2. My understanding is that the official method to disable slicing is setting 'slicer: null'. You may already have seen it, but there is some app.json documentation here:
    http://docs.sencha.com/cmd/guides/app_json.html

  3. #2
    Sencha Premium User
    Join Date
    Oct 2016
    Posts
    26
    Answers
    1

    Default

    same problem here...is there a way to completely disable the slicer and the generation of "example" folder ?

    Just a hint for Sencha....the app.json should have a better documentation (i often had to dig inside ant script for debug build errors)

  4. #3
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    My understanding is that the official method to disable slicing is setting 'slicer: null'. You may already have seen it, but there is some app.json documentation here:
    http://docs.sencha.com/cmd/guides/app_json.html

  5. #4
    Sencha Premium Member
    Join Date
    May 2015
    Posts
    14

    Default

    Thank you, Gary. Much appreciated.

    We did not know of the 'docs-devel' documentation.

    I think the comments in app.json are a bit counterintuitive. Like most sections, the slicer has an enable flag, however setting this flag to false does not have the desired effect. Setting the entire section to null was a wild guess for us, as we did not have any hint in documentation if this is even a viable option until we actually tried it. Now the development docs only show it for the compressor and without any explanation; this is a bit better but not great.

    I definitely would like to see better documentation.

  6. #5
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Sorry, the devel part of the link was a mistake. Link updated.

    The app.json doc page is relatively new, and we certainly expect that there will be improvements. I've shared your comments with our Documentation team to help make the next iteration better.

  7. #6
    Sencha Premium Member
    Join Date
    May 2015
    Posts
    14

    Default

    Excellent, thank you.

  8. #7
    Sencha Premium User
    Join Date
    Dec 2013
    Posts
    2

    Default

    I am also facing the same problem in Sencha CMD 6.5. I did add "slicer":null to app.json file but it didn't work.
    IcoFisher were you able to resolve the issue with this change only?

    Thanks,
    Abhishek

  9. #8
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Did you make the change to this section?
    Code:
        /**
         * Additional resources used during theme slicing operations
         */
        "slicer": {
            "js": [
                {
                    "path": "${app.dir}/sass/example/custom.js",
                    "isWidgetManifest": true
                }
            ],
            "output": {
                "appCache": {
                    "enable": false
                }
            },
            "cache": {
                "enable": false
            }
        },

  10. #9
    Sencha Premium Member
    Join Date
    May 2015
    Posts
    14

    Default

    Quote Originally Posted by Abhishek Jena View Post
    I am also facing the same problem in Sencha CMD 6.5. I did add "slicer":null to app.json file but it didn't work.
    IcoFisher were you able to resolve the issue with this change only?

    Thanks,
    Abhishek
    Yes, this works.

    For an application, change application.json and replace the whole "slicer": { ... }, section with "slicer": null, like Gary suggests. Make sure there are no other slicer sections that can interfere.

    For a package it is the same only in package.json; notice how SenchaCmd 6.5 added an extra "sencha" section, so you have to replace/add the slicer inside of that.

    Regards,
    Martin

  11. #10
    Sencha Premium User
    Join Date
    Dec 2013
    Posts
    2

    Default

    Thank You, Gary and Martin. It worked.

Page 1 of 2 12 LastLast

Similar Threads

  1. Theme slicer possible has a bug
    By mozily in forum Ext: Q&A
    Replies: 2
    Last Post: 14 Mar 2013, 7:31 AM
  2. Theme Slicer and the ext directory
    By toxkillfraex in forum Sencha Cmd
    Replies: 1
    Last Post: 9 Mar 2012, 12:16 AM
  3. Slicer help
    By Cuberic in forum Sencha Cmd
    Replies: 1
    Last Post: 30 Jan 2012, 7:09 PM
  4. [1.2.3] Why dont the Slicer not slice all images?
    By Dumbledore in forum Sencha Cmd
    Replies: 4
    Last Post: 30 Sep 2011, 7:53 AM
  5. help me, slicer
    By nailuo in forum Sencha Cmd
    Replies: 1
    Last Post: 3 Sep 2011, 4:19 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •