Results 1 to 3 of 3

Thread: Cannot get reactor-boilerplate started

    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha User
    Join Date
    Dec 2009

    Default Cannot get reactor-boilerplate started

    I have tried everything and i cannot get past the 2nd step (Creating a new application) in the Getting Started guide...

    I have posted a comment on this issue in github which seems very similar. Have a look there for the real details but essentially, when I run npm start it just hangs with the same error message each time...

    10% building modules 1/1 modules 0 active
    Project is running at http://localhost:8080/
    webpack output is served from /
    Content not from webpack is served from ./build
    404s will fallback to /index.html
    94% asset optimization
    building ExtReact bundle: ext => C:\sandbox\extjs-reactor\packages\reactor-boilerplate\build\ext-react
    (node:5256) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): TypeError: Cannot read property 'toString' of undefined
    I'm almost certain this is caused by some issue with sencha-cmd (see here for more analysis and evidence). This is a real pity as I was so looking forward to ExtReact and I can't even get it started.

  2. #2
    Sencha User
    Join Date
    Dec 2009


    The issue was indeed related to sencha-cmd. However, it was actually the JRE version which caused the error. Thanks to @israelroldan's suggested solution here.

    I upgraded Java to latest version (8), deleted node_modules/reactor-boilerplate folder (just to make sure I had a clean install) and then ran npm install followed by npm start. Everything worked perfectly this time.

  3. #3
    Sencha User
    Join Date
    Feb 2013


    Glad to hear that you got things working, and thanks for sharing the solution here with the community.

Similar Threads

  1. Getting Started
    By almcaffee in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 30 Dec 2015, 3:09 PM
  2. Reducing boilerplate
    By Josh.VanderLinden in forum Sencha Cmd
    Replies: 3
    Last Post: 20 May 2015, 2:53 PM
  3. getting started on mac
    By wmaa in forum Sencha Touch 2.x: Q&A
    Replies: 7
    Last Post: 22 Mar 2013, 5:14 AM
  4. Getting started
    By mntman in forum Sencha Touch 2.x: Q&A
    Replies: 3
    Last Post: 25 Apr 2012, 4:58 AM
  5. getting started
    By prince0901 in forum Sencha Touch 1.x: Discussion
    Replies: 3
    Last Post: 3 May 2011, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts