Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Google Feed API deprecated

    You found a bug! We've classified it as EXTJS-23455 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #11
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    169

    Default

    Quote Originally Posted by ashokkumar.ganesan1 View Post
    I am also facing a similiar issue. But this happens suddenly. Is there any change in google feed API in recent days ?
    Yes, Google feed API v1 (used by sencha) has been deprecated

  2. #12
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    We have created a thread with instructions on how to resolve this issue. More can be found here: https://www.sencha.com/forum/showthr...I-Load-Failure
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  3. #13
    Sencha Premium User
    Join Date
    Oct 2016
    Posts
    26

    Default

    This is also breaking 70% of the SDK examples and documentation.
    I hope for a very fast fix

  4. #14
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    Quote Originally Posted by mattia.pagliasso View Post
    This is also breaking 70% of the SDK examples and documentation.
    I hope for a very fast fix
    Can you be more specific about which ones are breaking? I know the Feed Viewer and Portal Demo require Ext.ux.google.Feeds so they are sure to break. If there are any other examples that require the class that will break too, but this would only affect specific examples and not such a large range you are referring to.

    As for the documentation, it should not be affected at all.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  5. #15

    Default not working for me!!

    Quote Originally Posted by tristan.lee View Post
    We have created a thread with instructions on how to resolve this issue. More can be found here: https://www.sencha.com/forum/showthr...I-Load-Failure
    Hi tristan,

    Tried solution mentioned for 5.X but didn't worked for me.

    using Sencha5.1.3.61.

    Unlike "/examples/ux/google/Feeds.js"(as mentioned in the solution document for 5.X) my feeds.js location is "\ext\src\ux\google\Feeds.js".
    Does that makes any difference??

    Secondly on changing requiresGoogle to _requiresGoogle, do we need to give any values to it.(previously { api:'feeds', nocss : true }).

    for the loader part I am giving the path that is available for me for ux folder i.e.
    Ext.Loader.setPath('ux', 'ext/src/ux'); instead of Ext.Loader.setPath('ux', 'examples/ux');

    Please let me know if you require any other details.

  6. #16
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    Quote Originally Posted by naveenyadav View Post
    Hi tristan,

    Tried solution mentioned for 5.X but didn't worked for me.

    using Sencha5.1.3.61.

    Unlike "/examples/ux/google/Feeds.js"(as mentioned in the solution document for 5.X) my feeds.js location is "\ext\src\ux\google\Feeds.js".
    Does that makes any difference??

    Secondly on changing requiresGoogle to _requiresGoogle, do we need to give any values to it.(previously { api:'feeds', nocss : true }).

    for the loader part I am giving the path that is available for me for ux folder i.e.
    Ext.Loader.setPath('ux', 'ext/src/ux'); instead of Ext.Loader.setPath('ux', 'examples/ux');

    Please let me know if you require any other details.
    The location described in the resolution guide is based off of the path I observed when downloading the framework. It sounds like it may have been moved for you (which is fine). You will need to edit the file where it exists in your project.

    As for renaming the variable, you need to do only that. Adding an underscore prevent the superclass from finding that config and making a request to the feeds API. So as long as the variable is renamed (or even just removed), there will be no issue. You can even delete the Feeds.js file is you prefer.

    Your loader is fine then since that is the actual location of that ux path.

    Unless you are actually requiring the file, you should not be running into the issue.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

Page 2 of 2 FirstFirst 12

Similar Threads

  1. [CLOSED] Google Map event.returnValue is deprecated
    By davide.peri in forum Sencha Touch 2.x: Bugs
    Replies: 2
    Last Post: 19 Dec 2013, 9:47 AM
  2. Google Feed API and Sencha Touch 2: add more entries
    By Tubia87 in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 11 Aug 2012, 6:33 AM
  3. google ads inside rss feed my demo
    By koko2589 in forum Community Discussion
    Replies: 0
    Last Post: 18 Jul 2010, 10:54 AM
  4. HOW to use rss in panel like Google AJAX Feed API - Google Code
    By koko2589 in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 28 Jun 2009, 2:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •