Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Google Feed API deprecated

    You found a bug! We've classified it as EXTJS-23455 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    169

    Default Google Feed API deprecated

    Hello, there is a big problem with ext/packages/ux/src/google/Feeds.js.
    At loading time it blocks my app because Feed API has been deprecated.

    ?file=feeds&v=1.x&output=nocss%3Dtrue&async=2:1 Uncaught Error: Module: 'feeds' not found!
    at ?file=feeds&v=1.x&output=nocss%3Dtrue&async=2:1
    (anonymous) @ ?file=feeds&v=1.x&output=nocss%3Dtrue&async=2:1


    https://developers.google.com/feed/v1/devguide


    Could you confirm it?

  2. #2
    Sencha Premium Member
    Join Date
    Sep 2013
    Posts
    14

    Default

    I can confirm we had a few stressful hours this morning due to this. However we don't use the Feeds UX, we had just included it accidentally, so it was just a matter of having it removed.

  3. #3
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    169

    Default

    The same for me... but it's always included in debug version.. What is the best way to exclude it from production when all Ext.* is included?

    I'm trying
    Code:
                        Ext.exclude([
                            'Ext.ux.dashboard.*',
                            'Ext.ux.dashboard.GoogleRssPart',
                            'Ext.ux.dashboard.GoogleRssView',
                            'Ext.ux.google.Api',
                            'Ext.ux.google.Feeds'
                        ]);
    but not working if I use Ext.require('Ext.*')

  4. #4
    Sencha Premium Member
    Join Date
    Sep 2013
    Posts
    14

    Default

    For us what I did was to remove the "ux"-package from the requires array in app.json and instead add the paths to the specific UX-packages that we use in the "classpath"-array.

  5. #5
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    169

    Default

    @sencha devs - what is the best way to exclude just google feeds ux (and leave all the other uxs included)?

  6. #6

    Default

    Is there an alternate to using Ext.ux.dashboard.GoogleRssPart besides waiting for a bug fix? We removed this part of our app but would really like to maintain our RSS functionality.

  7. #7

    Default

    Just experienced this bug with ux-all.js. Is there a reliable fix yet?

  8. #8
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    169

    Default

    I've hard-coded the framework in ext/pakcages/src/ux/google/Feeds.js - just change "extends" value to "Ext.Class" - this will work because google/Api.js calls the api onClassExtend method.

    (I know this is bad solution, but it works, expecially for those who are blocked because of useless google api feed.. )

  9. #9
    Sencha User
    Join Date
    Oct 2011
    Location
    Pune
    Posts
    6

    Default

    We had same issue and we have removed ux-all.js from our application and included require UX classes with minified code. You can minified require classes using sencha cmd then use in your application.
    Regards,
    Venish Khant

  10. #10
    Sencha Premium User
    Join Date
    Feb 2009
    Posts
    15

    Default

    I am also facing a similiar issue. But this happens suddenly. Is there any change in google feed API in recent days ?

Page 1 of 2 12 LastLast

Similar Threads

  1. [CLOSED] Google Map event.returnValue is deprecated
    By davide.peri in forum Sencha Touch 2.x: Bugs
    Replies: 2
    Last Post: 19 Dec 2013, 9:47 AM
  2. Google Feed API and Sencha Touch 2: add more entries
    By Tubia87 in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 11 Aug 2012, 6:33 AM
  3. google ads inside rss feed my demo
    By koko2589 in forum Community Discussion
    Replies: 0
    Last Post: 18 Jul 2010, 10:54 AM
  4. HOW to use rss in panel like Google AJAX Feed API - Google Code
    By koko2589 in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 28 Jun 2009, 2:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •