Results 1 to 5 of 5

Thread: Themer says "no settings exist for the selected component"

    Success! Looks like we've fixed this one. According to our records the fix was applied for CAT-520 in 1.1.0.
  1. #1
    Sencha Premium User
    Join Date
    Jun 2008
    Posts
    132
    Answers
    8

    Default Answered: Themer says "no settings exist for the selected component"

    Hi - I used Themer 1.0.3 to make some changes to my application theme, and it worked fine, but now when I open the theme in Themer I get the message "no settings exist for the selected component" for every component, and no SASS variables are ever listed. I believe this may have been triggered by some minor manual changes I made to some of my SASS - but I havent been able to track down what could have caused Themer to break.

    There's no error message displayed in the Themer.log.

    How can I resolve this issue and use Themer again?


    - bill

  2. Looks like this is a bug with Themer. It appears you defined a UI in the 'save' directory, but Themer does not know how to handle that UI (yet) and is failing.

    If you move your tabpanel UI to sass/src/Ext/tab/Panel.scss instead, Themer should load again.

    I only checked the 'classic' toolkit in your Theme, a similar modification would be necessary if you made changes like this in modern.

  3. #2
    Sencha - Ext JS Dev Team
    Join Date
    Mar 2016
    Posts
    64
    Answers
    20

    Default

    Hi Bill,

    That sounds like a Fashion error (and a bug in Themer for not reporting it). Can you try running `sencha app watch -fashion` from the command-line against the Preview App ([theme_dir]/.sencha/temp/Themer). Alternatively, I sent you an email if you want to reply with your Theme package and I can take a look.

    Either way, it would be good for us to understand your issue and make sure it's not a bug in Themer or Fashion.

  4. #3
    Sencha Premium User
    Join Date
    Jun 2008
    Posts
    132
    Answers
    8

    Default

    Hi Dan - thanks for replying. Interestingly when I run 'sencha app watch -fashion' against [theme_dir]/.sencha/temp/Themer no error is reported, and the app (well, the login dialog) displays fine at http://localhost:1841

    I've replied to your email with a copy of the theme...


    - bill

  5. #4
    Sencha - Ext JS Dev Team
    Join Date
    Mar 2016
    Posts
    64
    Answers
    20

    Default

    Looks like this is a bug with Themer. It appears you defined a UI in the 'save' directory, but Themer does not know how to handle that UI (yet) and is failing.

    If you move your tabpanel UI to sass/src/Ext/tab/Panel.scss instead, Themer should load again.

    I only checked the 'classic' toolkit in your Theme, a similar modification would be necessary if you made changes like this in modern.

  6. #5
    Sencha Premium User
    Join Date
    Jun 2008
    Posts
    132
    Answers
    8

    Default

    Perfect - that fixed the problem. Thanks.

Similar Threads

  1. Replies: 1
    Last Post: 16 Sep 2011, 2:53 AM
  2. Replies: 3
    Last Post: 22 Sep 2009, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •