Results 1 to 3 of 3

Thread: Sencha CMD 6.2 seems to ignore config "ext.dir"

  1. #1
    Sencha User
    Join Date
    Mar 2012

    Default Sencha CMD 6.2 seems to ignore config "ext.dir"

    When working locally, I have the framework files within workspace/ext which is working just fine.
    Since there's no need to put all framework files under source control, I need to have them outside of the project/workspace directory on the build server (e.g. D:\ext-6.2.0).

    I've managed to do this using a build command like sencha config --prop ext.dir="D:\ext-6.2.0" ... then app build classic which was working just fine with Ext 6.0.1 & Sencha Cmd

    However since I've upgraded my app to ExtJS 6.2.0 and Sencha Cmd I'm getting the following error if there's no ext framework directory within my workspace (e.g. after fresh checkout from source control on build server):

    [INF] Configuration property changed. Reloading build environment state.
    [ERR] Cannot satisfy requirements for "ext"!
    [INF] The following versions are available:
    [INF] ( ... compatible back to 4.0)
    [INF] ( ... compatible back to 4.0)
    [INF] ( ... compatible back to 4.0)
    [INF] ( ... compatible back to 4.0)
    [INF] ( ... compatible back to 6.0.0)
    [ERR] The following versions cannot be satisfied:
    [ERR] root: [email protected] (No matches!)
    [ERR] Cannot resolve package requirements

    Error level: 321
    I've also tried putting ext.dir="D:\ext-6.2.0" into all sencha.cfg files which doesn't work either.

    Also I've realized that the same error occurs, if I try to build the upgraded ExtJS 6.2.0 app with the old Sencha Cmd for which it seems that the problem is not within the new Sencha Cmd but the new framework version.

    Long story short:

    How can I build an ExtJS 6.2.0 app where the framework files are not saved within workspace/ext but somewhere else?

  2. #2
    Sencha - Engineering israelroldan's Avatar
    Join Date
    Nov 2011
    The Netherlands


    The framework needs to be in the workspace root, the directory name no longer needs to specifically be "ext".

    Thanks to the framework management commands, you can now have many frameworks in the same workspace, which is why setting "ext.dir" no longer works. The property that you want to set is "workspace.ext.path".

    Ultimately, I think the best approach in your case is to create a symlink that points to the directory you want, instead of passing this property each time.
    Israel Roldán | Senior Software Engineer (Framework tools)

  3. #3
    Sencha User
    Join Date
    Mar 2012


    Hy israelroldan,

    thanks for the answer so far!

    I can't get it to work using workspace.ext.path. I've tried the following variations:
    • Adding workspace.ext.path=D:\ext-6.2.0 to workspace/.sencha/workspace/sencha.cfg
    • Adding workspace.ext.path=D:\ext-6.2.0 to workspace/base-name/project-name/.sencha/app/sencha.cfg
    • Applying it via an Sencha CMD line argument (--prop workspace.ext.path="D:\ext-6.2.0")

    Your second suggestion, using a Symlink, works just fine and represents a feasible alternative approach.

    Nonetheless I'd still appreciate if we could figure out, why setting workspace.ext.path didn't work for me?

    Thanks & best regards

Similar Threads

  1. sencha app watch -> ignore all require
    By Silmortes in forum Sencha Cmd
    Replies: 2
    Last Post: 23 Aug 2016, 12:29 PM
  2. Replies: 2
    Last Post: 8 Jul 2016, 7:43 AM
  3. sencha app watch does not ignore *.swp files
    By movys in forum Sencha Cmd
    Replies: 3
    Last Post: 20 Aug 2015, 11:55 AM
  4. [FIXED] sencha app watch - how to ignore files?
    By brian428 in forum Sencha Cmd
    Replies: 12
    Last Post: 20 Feb 2015, 4:59 AM
  5. how to add -ignore in workspace sencha.cfg ?
    By maneljn in forum Sencha Cmd
    Replies: 1
    Last Post: 6 Nov 2012, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts