Results 1 to 2 of 2

Thread: Intellisense & App Watch not working with VS 2015 Enterprise

  1. #1

    Default Intellisense & App Watch not working with VS 2015 Enterprise

    I'm having trouble getting Intellisense & App Watch to work in Visual Studio Enterprise 2015 with the Sencha Plugin. This is on a Windows 7 VM, with Ruby 2.3.1, Sencha Cmd, Ext Js 6.2.0, and Visual Studio Enterprise 2015 Update 2 with Resharper Ultimate 2016.2 installed the version of the Sencha Plugin is 6.0.5. I have tried both attaching to an existing Web Application (preferred) as well as creating a new web application with Ext JS.

    With the existing application I right clicked on the solution and did Enable Sencha Ext Js Plugin for Project, and then did Add > New Item > Sencha > Ext Js App . The application files and folders appear to have been created successfully, however Intellisense doesn't show any options with the Sencha icon within an Ext Js Javascript file, and when I right click on the application folder that was created I see a sencha option for "Set as StartUp App". However, clicking on that does not change the option to "Start Sencha App Watch", also when I go to View > Other Windows > Sencha App Watch there are no applications appearing and I am unable to start/stop the application, which is also mentioned on this thread: trying to create the project shown in video. I can build manually with the Sencha Cmd Tool from the command line as well as start App Watch and run the application in a web browser (but not within Visual Studio).

    I've tried building within Visual Studio as well as closing the solution and reopening. I've also tried the suggestions in these threads: IntelliSense not working & Better .sencha-ide-config example.

    I've confirmed that the hidden json files in the \.sencha\temp\.ide\file.json & usage.json includes all the files within the Ext Js Application, yet Visual Studio will not autocomplete on both items within strings and standard Ext Commands/Variables. I have also confirmed that the options within Tools > Options > Text Editor > Javascription > General > Auto List Members is checked and Tools > Options > Sencha > Enable automatic intellisense in string literals is also checked. Any other thoughts as to why Intellisense isn't picking up?


  2. #2


    I have determined that this is more likely a Resharper Bug and have created: with JetBrains. However, I have a feeling that this will be something that both Sencha & JetBrains will have to work on together.

    I was hoping that I could just set Resharper to only use Visual Studio for JavaScript files and embedded JavaScript however that option was not working. To work around the issue, I went to Resharper > Manage Options (Select current solution) > Intellisense > General to use Visual Studio for all intellisense commands. And intellisense started returning as expected.

    To me this seems to be either a bug within Resharper or something the Sencha Plugin needs to detect and also setup within Resharper. Attached are examples of the differences with Resharper set as the default intellisense provider:

    With Resharper as the default provider:

    With Visual Studio as the default provider:

Similar Threads

  1. Replies: 6
    Last Post: 29 Jul 2016, 10:55 AM
  2. VS Plugin not working in 2015 Enterprise
    By egoodnoe in forum Visual Studio Plugin
    Replies: 5
    Last Post: 11 Nov 2015, 12:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts