Results 1 to 2 of 2

Thread: Error in require package created

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    fabio.policeno's Avatar
    Join Date
    Sep 2010
    Location
    Curitiba - Brazil
    Posts
    367

    Default Error in require package created

    Ext version tested:
    • Ext 6.0.2.437
    Sencha Cmd version tested:
    • 6.1.3.42
    Browser versions tested against:
    • Chrome
    Description:
    • After of create new package, not is possible require, failed when run sencha app refresh:
    Code:
    Sencha Cmd v6.1.3.42
    [INF] Processing Build Descriptor : classic
    [INF] Loading app json manifest...
    [ERR] C2008: Requirement had no matching files (Shares.Main) -- /Development/php/test-local/src/applets/shares/classic/src/view/main/Main.js:19:193
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExBuild: Failed to find any files for /Development/php/test-local/src/applets/shares/classic/src/view/main/Main.js::ClassRequire::Shares.Main
    [ERR]
    [ERR] Total time: 6 seconds
    [ERR] The following error occurred while executing this line:
    /Users/fabio/bin/Sencha/Cmd/6.1.3.42/plugins/ext/current/plugin.xml:425: The following error occurred while executing this line:
    /Development/php/test-local/src/applets/shares/.sencha/app/build-impl.xml:380: The following error occurred while executing this line:
    /Development/php/test-local/src/applets/shares/.sencha/app/init-impl.xml:382: com.sencha.exceptions.ExBuild: Failed to find any files for /Development/php/test-local/src/applets/shares/classic/src/view/main/Main.js::ClassRequire::Shares.Main
    Steps to reproduce the problem:
    • create app:
      Code:
      sencha -sdk /Development/php/ext-6.0.2/ generate app Test shares
    • generate package:
      Code:
      cd shares/
      Code:
      sencha generate package shares
    • in the package created, change package.json namespaces:
      Code:
      ...
      "namespace": "Shares", 
      ...
      "sass" : {
              "namespace": "Shares",
      ...
    • create view in the package to test (packages/local/shares/classic/src/Main.js):
      Code:
      Ext.define('Shares.Main', {
          extend: 'Ext.panel.Panel',
          xtype: 'shares',
          title: 'Shares',
          html: 'Shares content'
      });
    • finally, in Test.view.main.Main', add:
      Code:
      require: 'Shares.Main'
    • and change line 86 to:
      Code:
      xtype: 'shares'
    • so run:
      Code:
      sencha app refresh
    The result that was expected:
    • Successfully when run sencha cmd and work fine in browser without console errors
    The result that occurs instead:
    • Failed and error message and not found class from package
    PS:
    • In this versions has this problem described:
      Code:
      app.framework.version=6.0.2.437
      app.cmd.version=6.1.3.42
      (Last final version)
      Code:
      app.framework.version=6.2.0.589
      app.cmd.version=6.2.0.46
    • In this version, work fine:
      Code:
      app.framework.version=6.0.1.250
      app.cmd.version=6.0.2.14
    • In summary, after this old version, cmd or extjs was broked and no more fixed

  2. #2
    fabio.policeno's Avatar
    Join Date
    Sep 2010
    Location
    Curitiba - Brazil
    Posts
    367

    Default

    So?

Similar Threads

  1. Replies: 1
    Last Post: 22 Jul 2015, 2:29 PM
  2. Replies: 2
    Last Post: 6 Jan 2015, 8:15 AM
  3. Internet Explorer 10: Expected ';'. Error because of //@require @package in app.js
    By Arjen de Kivet in forum Sencha Architect 2.x: Bugs
    Replies: 4
    Last Post: 14 Oct 2013, 1:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •