Results 1 to 9 of 9

Thread: Insecure Application Cache deprecated in Chrome 50

    You found a bug! We've classified it as EXTJS-21051 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Ext JS Premium Member tangix's Avatar
    Join Date
    Mar 2010
    Location
    Stockholm, Sweden
    Posts
    741

    Default Insecure Application Cache deprecated in Chrome 50

    Ext version tested:
    • Ext 6.02.437

    Browser versions tested against:
    • Chrome 50.0.2661.94m

    Description:
    • Chrome started logging this message to the console after the last update:
      Use of the Application Cache is deprecated on insecure origins. Support will be removed in the future. You should consider switching your application to a secure origin, such as HTTPS. See https://goo.gl/rStTGz for more details.
      Location bootstrap.js

    Steps to reproduce the problem:
    • create a new universal project with CMD
    • run sencha app watch and open the project (Cmd only supports HTTP)

  2. #2
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

  3. #3
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    I thought I was able to reproduce this, but I misread the console messages. Can you provide me a screenshot of the warning you are seeing? By default, appCache looks to only be enabled for a production build so I am curious to know what you are seeing when running the development build from Cmd.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  4. #4
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    It looks like as long as you're using localhost, it's considered secure. If you use the IP of the server, then Chrome throws the warning.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  5. #5
    Ext JS Premium Member tangix's Avatar
    Join Date
    Mar 2010
    Location
    Stockholm, Sweden
    Posts
    741

    Default

    True - I am not using "localhost" I have an entry in the hosts file on Windows.2016-05-05_10-25-33.png

  6. #6
    Sencha Premium Member
    Join Date
    Feb 2012
    Posts
    303

    Default

    same problem here.

  7. #7
    Sencha Premium Member
    Join Date
    Sep 2014
    Location
    New Jersey
    Posts
    166

    Default

    I'm also experiencing this for the production version of my application.

    Any updates on this? Not a big deal but I'd love to clean up the console and remove that warning.

    Thanks!

  8. #8
    Sencha User
    Join Date
    Sep 2012
    Posts
    2

    Default

    To avoid console warning I have added in index.html
    PHP Code:
    if(!/https:/.test(location.protocol))
        
    delete window['applicationCache']; 

  9. #9
    Sencha Premium User
    Join Date
    Jul 2015
    Location
    Madrid
    Posts
    6

    Default

    Any progress?

Similar Threads

  1. Replies: 4
    Last Post: 27 Feb 2013, 1:39 PM
  2. Replies: 1
    Last Post: 31 Jan 2013, 3:27 AM
  3. application cache, sencha 2
    By mainstream in forum Sencha Touch 2.x: Q&A
    Replies: 4
    Last Post: 26 Mar 2012, 1:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •