Results 1 to 8 of 8

Thread: Grid & Grouping - Removing records leaves "ghosts" behind

  1. #1

    Default Grid & Grouping - Removing records leaves "ghosts" behind

    Hello every1.

    Im developing a grid with the grouping feature. However, i've been experiencing an issue which is that, after i remove the record ( .remove(selectedRecords); ) and sync the store, apparently, the grouping keeps the record on the grid. The first record I remove seems to disappear as intended but when i remove a second record, the first one returns. If i refresh the grid, all of them return.
    Its like the records are not really beeing removed or their ghosts are beeing left behind .
    I've checked the store and the database and they are removed successfuly.
    Aditionally, if i click one of the removed records, another record gets selected.

    I've tried reloading the store, refreshing the grid / view, collapsing the groups, etc. None solved this issue.

    This seems to happen only with the grouping feature enabled. If i disable / remove the grouping, the grid goes back to working properly.

    I've attached some screenshots to show this behaviour. They go by this order:
    Image grouping1 - This image shows the original state of the grid.
    Image grouping2 - This image is after deleting the "Test 2" record. All seems fine here, right?
    Image grouping3 - This image is how the grid looks after i remove the "Test 3" record. The "Test 2" record magically reappears.
    Image grouping4 - This image shows what happens if i hit my refresh button. All the record ("Test 2" and "Test 3") reappear. Adicionally, that selected record ("Wood Furniture") got selected after I clicked on the "Test 2" record.

    Am i doing something wrong, missing something or could this be a bug with the grouping feature?

    Thank you for any help in advance.

    Kind regards...
    Attached Images Attached Images

  2. #2


    Well, for now, i found a workaround for the issue by, programatically, disabling the feature and re-enabling it.
    This workaround, however, makes all groups become expanded and i have to find a way to collapse all and expand only the ones that were expanded b4 the delete.
    Anyways, its a workable solution, for now.
    However, i still think this issue with the grouping is still a bug or unintended mechanic.

  3. #3
    Sencha User
    Join Date
    Feb 2013


    Thanks for the report. Can you please post a test case which reproduces this issue?

  4. #4



    Here's a test case:

    Try to delete 2 features. The first feature u delete, everything seems ok. But additional feature deletes and the previous ones start reappearing.

    Also, after a bit more digging around and experimenting, i've been able to pin point the issue a bit more precisely to the store.sync(), meaning that, without the sync() the problem doesn't happen. But the minute i try to use a sync on my store, then the issue starts happening.

    Hope this helps.

  5. #5



  6. #6
    Sencha User
    Join Date
    Jun 2013


    Any progress or work around for that. I am facing same issue.


  7. #7
    Sencha User
    Join Date
    May 2016


    I have encountered the same bug/problem. Any news on this?

  8. #8
    Sencha - Support Team
    Join Date
    Oct 2011


    This issue has been fixed in ExtJS 6.2.0

Similar Threads

  1. Replies: 8
    Last Post: 10 Dec 2015, 2:19 AM
  2. Replies: 3
    Last Post: 23 Jun 2015, 11:28 PM
  3. Replies: 3
    Last Post: 28 Nov 2011, 5:28 AM
  4. Async tree - make empty nodes appear as "nodes", not "leaves"
    By mdmitry in forum Ext 3.x: Help & Discussion
    Replies: 3
    Last Post: 1 Mar 2010, 6:17 PM
  5. Replies: 0
    Last Post: 11 Oct 2007, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts