Results 1 to 6 of 6

Thread: Build and upgrade are both failing

  1. #1
    Sencha Premium Member
    Join Date
    Sep 2015
    Location
    Portland, Oregon
    Posts
    4

    Default Build and upgrade are both failing

    When I try to build my project I am getting the following:
    $ sencha app build -c production
    Sencha Cmd v5.1.3.61
    [INF] Processing Build Descriptor : default
    [WRN] The application was last modified by an older version of Sencha Cmd (4.0.4.84), current is 5.1.3.61. Please run 'sencha app upgrade -noframework' to update to
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.BasicException: java.lang.NullPointerException
    [ERR]
    [ERR] Total time: 5 seconds
    [ERR] The following error occurred while executing this line:
    c:\Users\kerrn\Documents\Dev\Git\cp\rfqs\32298\WMD\_senchaSource\.sencha\app\build-impl.xml:359: The following error occurred while executing this line:
    c:\Users\kerrn\Documents\Dev\Git\cp\rfqs\32298\WMD\_senchaSource\.sencha\app\js-impl.xml:11: com.sencha.exceptions.BasicException: java.lang.NullPointerException
    [ERR]
    The application was last modified by an older version of Sencha Cmd (4.0.4.84)
    the current is 5.1.3.61.
    Please run "sencha app upgrade" to update to 5.1.3.61.


    When I try to run upgrade I am getting the following:
    $ sencha app upgrade
    Sencha Cmd v5.1.3.61
    [INF] upgrading application
    [INF] Upgrading to sdk at c:\ext-4.2.3.1477
    [INF] Updating application and workspace from Ext JS ext-4.2.3.1147 / Cmd 4.0.4.84
    [INF] upgrading extjs 4.1 app structure
    [ERR] com.sencha.exceptions.ExScript: TypeError: Cannot read property "length" from null (anonymous#257)
    runAppUpgrade (anonymous:256)
    [anonymous] (anonymous:453)
    x_app_upgrade (anonymous:451)
    [ERR]
    The application was last modified by an older version of Sencha Cmd (4.0.4.84)
    the current is 5.1.3.61.
    Please run "sencha app upgrade" to update to 5.1.3.61.


    Any ideas what I need to fix?

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Does it work any better for you if you add the 'noframework' flag?
    Code:
    sencha app upgrade -noframework
    What version of Java are you running?

  3. #3
    Sencha Premium Member
    Join Date
    Sep 2015
    Location
    Portland, Oregon
    Posts
    4

    Default

    No, the -noframework switch give me the same results. I opened a ticket on this. So someone in Support is working with me on this.$ java -versionjava version "1.8.0_65"Java(TM) SE Runtime Environment (build 1.8.0_65-b17)Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)Thanks,Nathan

  4. #4
    Sencha Premium Member
    Join Date
    Sep 2015
    Location
    Portland, Oregon
    Posts
    4

    Default

    I've resolved this issue.

  5. #5
    Sencha User
    Join Date
    Dec 2015
    Location
    Norther Virginia
    Posts
    15

    Default

    How did you resolve this issue?

  6. #6
    Sencha Premium Member
    Join Date
    Sep 2015
    Location
    Portland, Oregon
    Posts
    4

    Default

    I needed to move my application into a template that my company uses. My development was using a later version of Sencha Command. I used Git Bash to grep through my repository looking for 4.0.4.84. I used Notepad++ to edit the records that I found. (A messy solution that I will have to improve on in the future.)

Similar Threads

  1. Upgrade from Ext JS 4.1 to 5.0 failing
    By noiks in forum Sencha Cmd
    Replies: 1
    Last Post: 2 Apr 2015, 5:43 AM
  2. sencha app upgrade failing
    By pbienick in forum Sencha Cmd
    Replies: 6
    Last Post: 30 Jan 2013, 4:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •