Results 1 to 6 of 6

Thread: BUG: After using any textarea in IE 11, the app goes slow forever. Fiddle inside.

    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1

    Default BUG: After using any textarea in IE 11, the app goes slow forever. Fiddle inside.

    Windows 7 and IE 11 tested.

    Ext JS 5 - 6 any version affected.

    When users have entered ANY textarea in the application. It is enough to just type a letter and then delete it again, Grids gets slower and leaks memory in IE11.

    Some grids are not noticeable but there are things that make it worse. Grouping makes it worse. If app is using @font-face it escalates into to the absurd.

    The fiddle adds and destroys a grid when you click a button. Try first by clicking the add grid button and then type something in the small textarea and click the add button again.

    Observe speed and the amount of memory used by the iexporer task in task manager.

    You need to be in IE 11 to see this.

    Solution is to disable spell checking in IE under "Manage Addons" or add the attribute spellcheck="false" to the body tag.

    Movie showing speed decrease and memory increase

    Movie showing how it looks when spell check is off:

  2. #2
    Sencha User
    Join Date
    Feb 2013


    Thanks for the report. I tried this several times using Windows 7 and IE 11, but I haven't seen the dramatic spike in memory usage yet. Does it take a while to manifest? Is the plugin you mentioned the standard included spell checker?

  3. #3


    Its noticeable right away. Especially on perfromance. It takes much longer to load the grid after you type anything in the textarea.

    It is the built in spell checker.

    I have updated the original post with movies showing the problem

  4. #4
    Sencha - Support Team keckeroo's Avatar
    Join Date
    Mar 2008
    Winnipeg, Canada


    Thanks for the report! I have opened a bug in our bug tracker.

  5. #5
    Sencha Premium User evant's Avatar
    Join Date
    Apr 2007
    Sydney, Australia


    Seems MS are aware of the issue:

    Going to mark this as closed, not much we can do here.

    There's a couple of suggestions here:

    a) Disable the addon
    b) Disable spellcheck on the body element
    Twitter - @evantrimboli
    Former Sencha framework engineer, available for consulting.
    As of 2017-09-22 I am not employed by Sencha, all subsequent posts are my own and do not represent Sencha in any way.

  6. #6


    Can confirm that <body spellcheck="false"> solved the problem.

    Important to note that this was introduced in a security update but MS hotfix comes as standard update. Might take time for corporate computers to get the fix.

    Link to hotfix:

Similar Threads

  1. [DUP] Combobox / Tagfield bind bug -> Fiddle inside
    By t.nissen in forum Ext 5: Bugs
    Replies: 1
    Last Post: 30 Mar 2015, 3:40 PM
  2. Replies: 5
    Last Post: 12 Mar 2015, 12:59 AM
  3. [OPEN] HtmlEditor disable bug: (fiddle inside)
    By sagoig in forum Ext 5: Bugs
    Replies: 1
    Last Post: 17 Sep 2014, 9:05 AM
  4. Replies: 1
    Last Post: 21 Jun 2011, 7:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts