Results 1 to 6 of 6

Thread: Can't connect to a localhost app using a bookmarklet

  1. #1
    Sencha Premium User
    Join Date
    Sep 2011
    Location
    Tamworth, NSW, Australia
    Posts
    1,271
    Answers
    13

    Default Answered: Can't connect to a localhost app using a bookmarklet

    I wasn't able to connect to the demo app so I tried the bookmarklet option for an app running on my own PC (Windows 8.1 with Chrome Version 46.0.2490.80 m). I get the following error in Chrome's developer tools:

    sencha-inspector.png

    My Sencha Inspector Port is set to 1839 and Sencha Inspector is definitely running... on my own PC, too.

  2. In the bookmarklet popup, there is an "Advanced Settings" button you can click to customize the domain/port.

  3. #2
    Sencha Premium User
    Join Date
    Sep 2011
    Location
    Tamworth, NSW, Australia
    Posts
    1,271
    Answers
    13

    Default

    It's a proxy problem. If I turn off all the checkboxes in Internet Properties for IE/control panel (which Chrome uses), then it works.

    Connecting to local.senchainspector.com for an app running local seems a bit weird. Turning off proxies also creates problems, unless I use one browser for development and another for everything else (which I find irritating; I prefer chrome as IE's developer tools are horrible, and Firefox is slow, although Firebug shows better detail).

    On a completely different matter, the anorexic font used by SI and its colour are difficult to read. I really have to lean in close to read it (I don't have to do this for anything else). It would be nice if we could change the font and/or increase the size.

  4. #3
    Sencha Developer
    Join Date
    Sep 2008
    Location
    Antioch, IL
    Posts
    1,516
    Answers
    99

    Default

    Quote Originally Posted by marc.fearby View Post
    Connecting to local.senchainspector.com for an app running local seems a bit weird. Turning off proxies also creates problems, unless I use one browser for development and another for everything else (which I find irritating; I prefer chrome as IE's developer tools are horrible, and Firefox is slow, although Firebug shows better detail).
    You can connect directly to http://localhost:1839 (or http://your-ip-address:1839) if you want; we default to local.senchainspector.com because we wanted to allow HTTPS connections without additional configuration. That doesn't sound to be an issue in your case, though.

  5. #4
    Sencha Premium User
    Join Date
    Sep 2011
    Location
    Tamworth, NSW, Australia
    Posts
    1,271
    Answers
    13

    Default

    I never saw a box asking me to enter a URL. Where do I type "localhost:1839"?

  6. #5
    Sencha Developer
    Join Date
    Sep 2008
    Location
    Antioch, IL
    Posts
    1,516
    Answers
    99

    Default

    In the bookmarklet popup, there is an "Advanced Settings" button you can click to customize the domain/port.

  7. #6
    Sencha Premium User
    Join Date
    Sep 2011
    Location
    Tamworth, NSW, Australia
    Posts
    1,271
    Answers
    13

    Default

    Sorry, I didn't notice that. I just looks like a heading to me. That works.

Similar Threads

  1. [FIXED] Problem connection to Inspector with bookmarklet from Firefox
    By dmurat in forum Sencha Inspector
    Replies: 2
    Last Post: 19 Aug 2015, 4:09 AM
  2. Unable to connect when not using localhost
    By thantous in forum Sencha Inspector
    Replies: 1
    Last Post: 17 Jul 2015, 4:21 AM
  3. A bookmarklet to log all Ext events to the console.
    By Animal in forum Community Discussion
    Replies: 9
    Last Post: 1 Feb 2012, 1:50 PM
  4. Localhost Problem
    By Phpex in forum Ext 2.x: Help & Discussion
    Replies: 6
    Last Post: 18 Nov 2007, 11:01 AM
  5. [NEWS] VERY COOL Bookmarklet Element Inspector
    By ReyBango in forum Community Discussion
    Replies: 5
    Last Post: 3 Aug 2007, 11:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •