Results 1 to 5 of 5

Thread: Supported browsers for Triton theme

  1. #1
    Sencha Premium Member
    Join Date
    Sep 2010
    Posts
    51

    Default Answered: Supported browsers for Triton theme

    Hi all,
    i've noticed a different behaviour between browsers in panel heading rendering.
    I've tested in FF 13 and the panel heading does not have any background color, while the same code in chrome 45 and IE 10 shows the right color (#5FA2DD blue).

    Is this a bug or the older browser it's just not supported? If so, there is a matrix where to know which browsers are supported for the various themes?

    Thanks in advice, GXT 4 Rocks!

  2. GXT 4 and Triton theme will be supported from FF39 and Chrome 43. If there are bugs reported in older versions, we may elect to fix them on a case-by-case basis; however, the intent of evergreen browsers is that the end user should always have a recent version so it doesn't make sense for new a version of GXT to support very old versions of auto-updating browsers.

  3. #2
    Sencha Sr Product Manager
    Join Date
    Jan 2012
    Location
    Arlington, WA
    Posts
    1,178
    Answers
    12

    Default

    We won't support Firefox 13. Why do you use such an old version?

    We know about some of the issues with triton working with old browsers that we do support.

    http://docs.sencha.com/gxt/4.x/getti.../Versions.html - The supported versions are here.

  4. #3
    Sencha Premium Member
    Join Date
    Sep 2010
    Posts
    51

    Default

    Thanks for your answer.
    The supported browsers matrix you linked does not target a specific mininum version for firefox (and chrome).
    I have used the standard blue theme with any issue in FF13, so it would be nice to know the minimum supported version for the different themes.

    The reason i still use such an old browser it's because a customer of mine does (he install machines inside his productive environment from an os image bundled with FF13 with no autoupdate enabled - by the way from the productive env they can only see corporate network).

  5. #4
    Sencha User
    Join Date
    Nov 2011
    Posts
    8
    Answers
    2

    Default

    GXT 4 and Triton theme will be supported from FF39 and Chrome 43. If there are bugs reported in older versions, we may elect to fix them on a case-by-case basis; however, the intent of evergreen browsers is that the end user should always have a recent version so it doesn't make sense for new a version of GXT to support very old versions of auto-updating browsers.

  6. #5
    Sencha Premium Member
    Join Date
    Sep 2010
    Posts
    51

    Default

    Thanks for your answer,
    that's ok, I just wanted to know exactly the supported version considering that the blue and gray themes do support older versions and there's no declared minimum version number in the docs for the triton and neptune themes (just says that support FF and Chrome).

Similar Threads

  1. Triton Theme missing from GXT 4 EA?
    By rdrever in forum GXT 4.x Q&A
    Replies: 3
    Last Post: 24 Sep 2015, 8:14 PM
  2. triton theme combobox caret icon glitch
    By juanbill in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 23 Jul 2015, 6:25 PM
  3. Jetty 9 with Theme Triton issues
    By andersonv1 in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 3 Jun 2015, 3:26 PM
  4. Version 3 not supported for updated browsers?
    By rich02818 in forum Ext 3.x: Help & Discussion
    Replies: 24
    Last Post: 24 Apr 2012, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •