Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Upgrade font-awesome package to lastest version (4.4.0)

  1. #11
    Sencha User
    Join Date
    Nov 2009
    Location
    Aveiro, Portugal
    Posts
    47
    Answers
    3

    Default Update fail

    I tried to upgrade, but i also receive a lot of warnings. I ended with no icons at all.

    Code:
    cd ~/recv
    wget http://fortawesome.github.io/Font-Aw...some-4.5.0.zip
    unzip font-awesome-4.5.0.zip
    
    cd ~/WebstormProjects/MyDashBoard
    cd ext/packages/font-awesome/resources
    mv fonts fonts.old
    cp -a ~/recv/font-awesome-4.5.0/fonts .
    
    cd ../sass/
    mv etc etc.old
    cp -a ~/recv/font-awesome-4.5.0/scss etc
    
    cd ../../../sass/etc/
    mv font-awesome-variables.scss font-awesome-variables.scss.old
    cp ~/recv/font-awesome-4.5.0/scss/_variables.scss font-awesome-variables.scss
    
    cd ../../packages/
    sencha package build

  2. #12
    Sencha Premium Member
    Join Date
    Nov 2010
    Posts
    53
    Answers
    2

    Default

    To hide warnings manually add following lines to _variables.scss (they were in original file):

    First line
    Code:
    //# fashion warn -elevation
    Last line
    Code:
    //# fashion warn +elevation
    Quote Originally Posted by juljupy
    Hi, i've updated font awesome to the last version 4.4.0 with these steps:

    - Download font awesome zip from http://fortawesome.github.io/Font-Awesome/ and decompres it

    - Then replace in your_project/ext/packages/font-awesome/resources/fonts files from font-awesome_decompressed_folder/fonts/

    - Then replace in your_project/ext/packages/font-awesome/sass/etc files from awesome_decompressed_folder/scss

    - Then replace the content in the file your_project/ext/sass/etc/font-awesome-variables.scss for the content of the file awesome_decompressed_folder/scss/_variables.scss

    - Then run "sencha package build" into your_project/ext/packages.

    It took a little time because it builds all theme and ux packages.

    Now i can use the new icons from font-awesome 4.4.0

    Hope it helps.

  3. #13
    Sencha Premium Member
    Join Date
    Apr 2013
    Posts
    127
    Answers
    3

    Default

    Anyone tried creating a package for FontAwesome 5 yet?

  4. #14
    Sencha Premium Member Zdeno's Avatar
    Join Date
    Nov 2009
    Location
    Prague
    Posts
    769
    Answers
    38

    Default

    Quote Originally Posted by [email protected] View Post
    Anyone tried creating a package for FontAwesome 5 yet?
    It's not quite simple because Sencha hardcoded font-awesome to neptune and material theme so you have to replace font-awesome with font-awesome-pro package in neptune theme. However I'm facing issue with Sencha Themer

  5. #15

    Default

    Quote Originally Posted by [email protected] View Post
    Anyone tried creating a package for FontAwesome 5 yet?
    I tried upgrading font-awsome to version free-5.0.6.

    details:
    https://qiita.com/yamayamayamaji/ite...e5809cd17fced8

    indexes:

    1. Get Font Awesome zip file
    2. Replace font files
    3. Replace sass files
    4. Edit /sass/etc/all.scss
    5. Edit /sass/src/all.scss
    6. Edit /sass/etc/_icons.scss
    7. Edit /sass/etc/_variables.scss
    8. Edit fa-brands.scss, fa-regular.scss, fa-solid.scss in /sass/etc/

    It seems to be going well so far. Hope it helps.

  6. #16
    Sencha Premium Member Zdeno's Avatar
    Join Date
    Nov 2009
    Location
    Prague
    Posts
    769
    Answers
    38

    Default

    I solved the problem using variables from fa4 version. Intead of replacing code in current package I would recommend you create new font package. Sencha can simply replace the code in future version. However with new package you will have cover more issues so I totally understand why do you replace code in existing.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Font Awesome
    By ssamayoa in forum Sencha Architect 2.x: Help & Discussions
    Replies: 14
    Last Post: 17 Mar 2015, 12:42 AM
  2. How to upgrade version of cmd for a package
    By Gordonh in forum Sencha Cmd
    Replies: 1
    Last Post: 3 Sep 2014, 9:40 PM
  3. [FIXED] Sencha Cmd package version upgrade problem
    By Fredric Berling in forum Sencha Cmd
    Replies: 3
    Last Post: 19 Feb 2014, 11:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •