Results 1 to 2 of 2

Thread: Unable to connect when not using localhost

  1. #1
    Sencha User
    Join Date
    Oct 2011
    Posts
    50

    Default Answered: Unable to connect when not using localhost

    Hello,

    Do to circumstances beyond my control I can not run my application via localhost. As well, I can't run the app through sencha's webserver due to authentication and authorization.

    I get around the localhost issue by simply adding a host entry (mac osx) and point a domain name at 127.0.0.1, such as foo.mydomain.com. When doing this, there does not seem to be a way to connect to Sencha Inspector. I have tried both setting it up in code and using the bookmarklet.

    I am using HTTPS as well. From Chrome's 'net' debug window I can see a connection to the Inspectors webserver to retrieve inspector.js but the connection is never shown.

    Any thoughts on why the connection can't be made if not using localhost?

    Thanks

  2. So there may be two things going on here:

    First, you're using HTTPS. The EAP ships with a self-signed SSL certificate for our internal server, so it's possible that your connection to https://localhost:3000 gets refused until you manually accept our certificate. (This will be fixed in our upcoming beta). To check, simply visit that URL in your browser -- you may get prompted to manually accept our cert.

    Second, what browser are you using? IE11 blocks web socket connections to localhost unless you disable some security feature, so that could be a problem.

  3. #2
    Sencha Developer
    Join Date
    Sep 2008
    Location
    Antioch, IL
    Posts
    1,516
    Answers
    99

    Default

    So there may be two things going on here:

    First, you're using HTTPS. The EAP ships with a self-signed SSL certificate for our internal server, so it's possible that your connection to https://localhost:3000 gets refused until you manually accept our certificate. (This will be fixed in our upcoming beta). To check, simply visit that URL in your browser -- you may get prompted to manually accept our cert.

    Second, what browser are you using? IE11 blocks web socket connections to localhost unless you disable some security feature, so that could be a problem.

Similar Threads

  1. Direct Exception - Unable to connect to server
    By rstanl1 in forum Ext 3.x: Help & Discussion
    Replies: 3
    Last Post: 30 Apr 2013, 4:50 PM
  2. Ajax localhost URL and online URL
    By prakseb in forum Sencha Touch 2.x: Q&A
    Replies: 3
    Last Post: 28 Apr 2013, 3:52 AM
  3. running samples on localhost
    By hcimadomo in forum Ext GWT: Discussion
    Replies: 0
    Last Post: 9 Feb 2010, 7:47 AM
  4. Advanced Combobox with Localhost
    By vishesh in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 21 Feb 2009, 9:40 AM
  5. Localhost Problem
    By Phpex in forum Ext 2.x: Help & Discussion
    Replies: 6
    Last Post: 18 Nov 2007, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •