Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Tooltips not working when button is disabled. Intended?

    You found a bug! We've classified it as EXTJS-18529 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1

    Default Tooltips not working when button is disabled. Intended?

    Hello.
    On some of my controllers, i had a command adding tooltips to a few buttons using some code similar to the following:
    Code:
    view.lookupReference('button1').setTooltip('teste');
    As stated, the tooltips were working correctly.
    After updating my project to Extjs 6.0.0.480, these tooltips have stopped working (not showing) if the button is disabled. They still work (show) if the button is enabled.
    Is this intended or a possible bug?

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    I think it's a bug, since I believe the tooltip has displayed on disabled buttons since at least 4.1.x. I'll move this thread to the Bugs forum.

  3. #3
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

  4. #4

    Default

    Ok... Thanks a lot.

  5. #5
    Ext JS Premium Member raphael.franchet's Avatar
    Join Date
    Mar 2009
    Location
    Toulouse, France
    Posts
    96

    Default

    I made a fiddle https://fiddle.sencha.com/#fiddle/rha with 3 different ways of making tooltips. It never works on disabled buttons.It is quite anoying.It is not working in 6.0.0 (nor in nightly) but working in 5.1.1 and 4.2.3
    Best regards,
    Raphael

  6. #6
    Sencha Premium Member
    Join Date
    May 2015
    Posts
    2

    Default It doesn't work in 5.1.2.748 either

    I'm currently using version 5.1.2.748 and the tooltip won't show in a disabled button.

  7. #7
    Sencha Premium Member
    Join Date
    Jul 2015
    Posts
    33

    Default

    +1 This is pretty annoying.

    Any idea on when this will be resolved?

    H

  8. #8
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    No news yet, but the bug ticket has a high priority so I expect this will get fixed soon.

  9. #9
    Sencha Premium Member
    Join Date
    Aug 2010
    Location
    Germany
    Posts
    35

    Default

    Any news to this topic? Its a litte bit confusing without displaying a tooltip on a disabled button :/

  10. #10
    Sencha Premium User
    Join Date
    Oct 2015
    Location
    Arvada, CO
    Posts
    76

    Default

    To get the functionality back to how it was in previous versions, you can remove the following CSS property that was added:

    Code:
    /* packages/ext-theme-base/sass/src/Component.scss:189 */
    .#{$prefix}item-disabled,
    .#{$prefix}item-disabled * {
        cursor: default;
        pointer-events: none; // prevents :hover styling on child elements
    }
    That line prevents the hover styling, but it also prevents the tooltip from showing. If this is taken out, the tooltip now shows, but you'll sometimes see the pointer cursor show up... which is why I'm assuming this property was added in.

Page 1 of 2 12 LastLast

Similar Threads

  1. Tooltips appearing on disabled objects
    By iamcootis in forum Ext: Discussion
    Replies: 1
    Last Post: 27 Mar 2014, 8:10 AM
  2. [OPEN] Disabled EXT field tooltips not showing in FireFox
    By AGregory in forum Ext:Bugs
    Replies: 4
    Last Post: 6 Mar 2013, 5:08 AM
  3. Browse button working when disabled
    By naveen2k6 in forum Ext 3.x: Help & Discussion
    Replies: 0
    Last Post: 14 Feb 2011, 11:53 PM
  4. ToolTips on disabled elements
    By jraue in forum Community Discussion
    Replies: 1
    Last Post: 9 Apr 2009, 1:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •