Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Tooltips not working when button is disabled. Intended?

    You found a bug! We've classified it as EXTJS-18529 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #11
    Sencha Premium Member
    Join Date
    Aug 2010
    Location
    Germany
    Posts
    35

    Default

    Hi WO_Jef,

    are you sure that your code is matching to Ext 6? I could not find any sass config for Component.sass :/

  2. #12
    Sencha Premium User
    Join Date
    Oct 2015
    Location
    Arvada, CO
    Posts
    76

    Default

    Yessir, you can see it in action here.

  3. #13
    Sencha Premium Member
    Join Date
    Aug 2010
    Location
    Germany
    Posts
    35

    Default

    Hey! thank you with the fiddle example. I implemented this in my application and works

  4. #14
    Sencha Premium Member
    Join Date
    Feb 2014
    Location
    Vietnam
    Posts
    10

    Default

    Hi WO_Jef,

    Thanks for your solution. I could have a concern that can we override the Component.scss with new class without pointer-events property instead remove it in Ext theme base? (E.g: I create a new class name Component.scss and in that I have only
    Code:
    .#{$prefix}item-disabled,
    .#{$prefix}item-disabled * {
        cursor: default;
    }

  5. #15
    Sencha Premium Member
    Join Date
    Jun 2012
    Posts
    28

    Default

    Hey, we have the same issue in ExtJS 5.1.3 and would be glad if someone could fix this.

  6. #16
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Thanks for the update. The EXTJS-18529 ticket covers 5.x as well.

  7. #17

    Default

    Quote Originally Posted by Tsunami2069 View Post
    Hello.
    On some of my controllers, i had a command adding tooltips to a few buttons using some code similar to the following:
    Code:
    view.lookupReference('button1').setTooltip('teste');
    As stated, the tooltips were working correctly.
    After updating my project to Extjs 6.0.0.480, these tooltips have stopped working (not showing) if the button is disabled. They still work (show) if the button is enabled.
    Is this intended or a possible bug?
    You can do this programmaticly:


    Code:
    var button={
            xtype : 'button',
            tooltip: 'Tooltip',
            text:'Text',
            style: {
                pointerEvents: 'all'
            }
        };
    Or after the component is initialized:


    Code:
     button.setStyle({pointerEvents: 'all'});

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Tooltips appearing on disabled objects
    By iamcootis in forum Ext: Discussion
    Replies: 1
    Last Post: 27 Mar 2014, 8:10 AM
  2. [OPEN] Disabled EXT field tooltips not showing in FireFox
    By AGregory in forum Ext:Bugs
    Replies: 4
    Last Post: 6 Mar 2013, 5:08 AM
  3. Browse button working when disabled
    By naveen2k6 in forum Ext 3.x: Help & Discussion
    Replies: 0
    Last Post: 14 Feb 2011, 11:53 PM
  4. ToolTips on disabled elements
    By jraue in forum Community Discussion
    Replies: 1
    Last Post: 9 Apr 2009, 1:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •