Page 65 of 97 FirstFirst ... 1555636465666775 ... LastLast
Results 641 to 650 of 965

Thread: [1.0] Grid RowActions Plugin

  1. #641
    Sencha User razvanioan's Avatar
    Join Date
    Feb 2008
    Location
    Romania
    Posts
    135

    Default

    Thanks, I will give it one more try and post here if I'll find a solution.

  2. #642

    Default No icons in rowActions

    Hi,

    I am "another stupid user" who can't see icons.

    I try to describe my code as good as I can.

    I have rows in my css file:
    .an-icon {
    background-image: url(ico/icon_email.png) !important;
    }

    rows from my js file:
    this.action = new Ext.ux.grid.RowActions({
    header:'Actions'
    ,keepSelection:true
    ,actions:[{
    iconIndex:'action1'
    ,qtipIndex:'qtip1'
    ,iconCls:'an-icon'
    ,tooltip:'Open'
    },{...

    I can see Action cell in my grid. I can click on it. But no icon.

    some rows from generated HTML:
    <div class="x-grid3-cell-inner x-grid3-col-ext-gen13" unselectable="on">
    <div class="ux-row-action">
    <div class="ux-row-action-item " qtip="" style=""/>
    <div class="ux-row-action-item " qtip="" style=""/>
    <div class="ux-row-action-item " qtip="" style="background-color: yellow;"/>
    </div>
    </div>

    Any hints?

  3. #643
    Sencha - Community Support Team jsakalos's Avatar
    Join Date
    Apr 2007
    Location
    Slovakia
    Posts
    27,664

    Default

    Check paths to icon images, your custom css and Firebug Net tab to see if icon images are loaded. If you see 404 in the net tab the problem is most likely a wrong path.
    Jozef Sakalos, aka Saki

    Education, extensions and services for developers at new http://extjs.eu
    News: Grid MultiSearch Plugin, Grid MultiSort Plugin, Configuring ViewModel Hierarchy


  4. #644

    Default

    Tnx,

    No any 404.
    If I explore firebug NET tab I can't see any request to my custom icon

  5. #645
    Sencha - Community Support Team jsakalos's Avatar
    Join Date
    Apr 2007
    Location
    Slovakia
    Posts
    27,664

    Default

    Where do your icons come from? Store or statical? iconIndex and iconCls are mutually exclusive.
    Jozef Sakalos, aka Saki

    Education, extensions and services for developers at new http://extjs.eu
    News: Grid MultiSearch Plugin, Grid MultiSort Plugin, Configuring ViewModel Hierarchy


  6. #646

    Default

    They are static.
    I defined both IconIndex and iconCls because i show it in example.

    Removed iconIndex and it helped. Tnx a lot man. If you happen to visit Estonia I'll buy a beer for you

    Best regards, Margusja

  7. #647
    Sencha User
    Join Date
    Nov 2008
    Posts
    61

    Default compatibility with ext-3.0.0

    Hi,
    I have just switched over to ext 3.0.0 from 2.2.0.
    I use RowActions with the 2.2 version in a grid and it works fine.
    I switch over to 3.0 and the icons do not appear.
    I switch back and it works again.
    I checked the net traffic and this load OK with 3.0

    Any idea what might be causing this?
    Thanks for the help.
    SWK

  8. #648
    Sencha - Community Support Team jsakalos's Avatar
    Join Date
    Apr 2007
    Location
    Slovakia
    Posts
    27,664

    Default

    Are you using the latest version of RowActions? It works for me with Ext 3.x.
    Jozef Sakalos, aka Saki

    Education, extensions and services for developers at new http://extjs.eu
    News: Grid MultiSearch Plugin, Grid MultiSort Plugin, Configuring ViewModel Hierarchy


  9. #649
    Sencha User
    Join Date
    Nov 2008
    Posts
    61

    Default

    Right, I get the latest version and now it works
    (or the reason it doesn't is probably not because of RowActions).

    Thanks for the help.
    SWK

  10. #650

    Default Ext.ux.grid.RowActions Plugin bigger icons

    Hi,

    I am using Ext.ux.grid.RowActions user extension by jsakalos http://rowactions.extjs.eu

    I want to use bigger icons for row actions. Currently the plug-in only support 16x16 icons. I tried playing around with provided CSS but it seem like nothing is really working.

    I will be glad someone can help me out here.

    Thanks

Page 65 of 97 FirstFirst ... 1555636465666775 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •