Results 1 to 2 of 2

Thread: Compiler warning "clear.gif"

  1. #1
    Sencha Premium Member
    Join Date
    Jul 2014
    Posts
    20

    Default Compiler warning "clear.gif"

    Hi,

    since we're using GWT 2.7 and GXT 3.1.2 we get a compiler warning.

    Code:
    [INFO] [INFO] Compiling module at.gevas.lagis.s.web.main
    [INFO] [INFO]    Computing all possible rebind results for 'com.sencha.gxt.theme.blue.client.window.BlueWindowAppearance.BlueWindowDivFrameResources'
    [INFO] [INFO]       Rebinding com.sencha.gxt.theme.blue.client.window.BlueWindowAppearance.BlueWindowDivFrameResources
    [INFO] [INFO]          Invoking generator com.google.gwt.resources.rebind.context.InlineClientBundleGenerator
    [INFO] [INFO]             Preparing method background
    [INFO] [INFO]                [WARN] Resource 'com/sencha/gxt/core/public/clear.gif' was located via ClassLoader. As a result changes in that resource will not be reflected in per-file recompiles. It should be registered via  <source /> or <resource /> entry in your .gwt.xml. In a future version of GWT, we will remove this fallback and your application will stop compiling
    [INFO] [INFO]       Rebinding com.sencha.gxt.theme.blue.client.window.BlueWindowAppearance.BlueWindowDivFrameResources
    Our gwt.xml. file looks like this.
    Code:
    <module rename-to='index'>
           <inherits name="com.google.gwt.user.User" />
     
           <inherits name="com.sencha.gxt.ui.GXT" />
           <!-- Logging -->
           <inherits name="com.google.gwt.logging.LoggingDisabled" />
           <set-property name="gwt.logging.enabled" value="TRUE" />
           <set-property name="gwt.logging.logLevel" value="INFO" />
     
           <!-- GXT stylesheet -->
           <stylesheet src="reset.css" /> <!-- <<<< Sets up the GXT default stylesheet -->
     
           <!-- Set locale - all gui elements of gwt/gxt will be translated -->
           <extend-property name="locale" values="de" />
     
           <entry-point class="at.gevas.lagis.s.web.client.Main" />
     
           <!-- Super Dev mode -->
           <add-linker name="xsiframe"/>  
           <set-configuration-property name="devModeRedirectEnabled"
                 value="true" />
           <set-property name="compiler.useSourceMaps" value="true" />
           <collapse-all-properties/>
     
           <!-- Sub-Directories which will be converted into javascript -->
           <source path="client" />
           <source path="share" />
     
    </module>
    How do we can solve this issue? Any hints are welcome.

    Thank you

    Sven

  2. #2
    Sencha User
    Join Date
    Sep 2014
    Posts
    1

    Default

    We are facing the same warning.
    Is there any solution known to this?

    Thomas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •