Results 1 to 5 of 5

Thread: Ext.form.Panel doesn't appear with IE 9 & 10

  1. #1
    Sencha User
    Join Date
    Nov 2014
    Posts
    3

    Default Ext.form.Panel doesn't appear with IE 9 & 10

    Hello !
    This is a form which doesn't appear at all with IE 9 & 10, while it works with all others browsers.
    I'm using ExtJS 4.
    If anyone has got an idea, thanks a lot !

    Code:
    Ext.require([
        'Ext.form.*'
    ]);
    
    
    var authentification_form = Ext.create('Ext.form.Panel', {
        frame: false,
        width: 412,
    
    
        // The form will submit an AJAX request to this URL when submitted
        url: base_alias + '/index/index',
    
    
        // Fields will be arranged vertically, stretched to full width
       // layout: 'anchor',
        defaults: {
            anchor: '100%'
        },
            
        fieldDefaults: {
            labelAlign: 'left',
            labelWidth: 90,
            anchor: '100%'
        },
    
    
        // The fields
        defaultType: 'textfield',
        items: [{
            fieldLabel: 'Societe',
            name: 'soc',
            allowBlank: false,
            invalidCls: 'obligatoire'
        },{
            fieldLabel: 'Identifiant',
            name: 'login',
            allowBlank: false,
            invalidCls: 'obligatoire'
        },{
             fieldLabel: 'Mot de passe',
            name: 'mpass',
            inputType: 'password',
            allowBlank: false,
            invalidCls: 'obligatoire'
        }], 
        
        
    
    
        // Reset and Submit buttons
        buttons: [/*{
            text: 'Annuler',
            handler: function() {
                this.up('form').getForm().reset();
            }
        }, */{
            text: 'Connexion',
            id: 'submit_login',
            formBind: true,
            disabled: true,
            handler: function() {
                var form = this.up('form').getForm();
                if (form.isValid()) {
                    form.submit({
                        waitTitle: "Connexion...",
                        waitMsg: "Verification des informations en cours...",
                        success: function(form, action) {
                            if (action.result.prem_connexion == "A") 
                                show_administrateur_modif();      
                            else if (action.result.prem_connexion == "U") 
                                show_utilisateur_modif();   
                            else 
                                document.location.href = document.location.href + 'index/accueil';
                        },
                        failure: function(form, action) {
                            Ext.Msg.alert('Echec de connexion', action.result.msg);
                            Ext.Msg.show({
                                title:'Echec de connexion',
                                msg: action.result.msg,
                                buttons: Ext.Msg.OK,
                                icon: Ext.Msg.WARNING
                           });
                        }
                    });
                }
            }
        }]
    });

  2. #2
    Sencha User
    Join Date
    Jun 2007
    Location
    Littleton, Colorado, USA
    Posts
    707
    Answers
    25

    Default

    What are you doing with the form to display it?

    I threw your code into a fiddle and made 2 changes. Displayed okay in chrome 26/IE 9 with Ext JS 4.2.1.

    1. Added renderTo
    2. commented the url since base_alias doesn't exist in the provided code.

    Code:
     renderTo: Ext.getBody(),
    
    
        // The form will submit an AJAX request to this URL when submitted
      //  url: base_alias + '/index/index',

  3. #3
    Sencha Premium User
    Join Date
    Nov 2014
    Location
    Kansas
    Posts
    781
    Answers
    102

    Lightbulb

    Here's the example fiddle.


  4. #4
    Sencha User
    Join Date
    Jun 2007
    Location
    Littleton, Colorado, USA
    Posts
    707
    Answers
    25

    Default

    Is displaying okay for me in IE9. Works in the forum or opened in fiddle. I opened the dev tools after it wworked to display the browser info. The browser version is 9.0.8112.16421, update version 9.0.33.

    Form-IE9.jpg

  5. #5
    Sencha User
    Join Date
    Nov 2014
    Posts
    3

    Default

    I think you're right. The pb seems to be something else. If i find it, i'll tell you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •