Sencha Cmd version(s):
  • Sencha Cmd 4.0.1.45

Operating System

  • Mac OS X 10.7.5

Framework used:

  • Sencha Touch 2.3.1
  • Cordova 3.2.0
  • Architect 3.0.3

Description:
  • Building a release version of my app does not run on the device.


Up until now I have been able to build and install my app on my phone just using:

Code:
sencha app build native
This produces an AI-debug.apk which works well locally but cannot be uploaded to the Play store as it is debug. Uploading this file gave an error that it was signed with a debug certificate.

So, I have tried another build using:

Code:
sencha app package build ./packager.json
This runs through and produces an AI.apk file which happily installs. However, this doesn't run. It starts and just shows the icon and title across the top of the screen.

The packager.json file is set to release and I have updated the keys/certs to the appropriate locations. I have also updated the AndroidManifest.xml to set android:debuggable:false.

When I compare the debug package and the release package, the release packages is missing the www level so all files are just in assets. Is this correct or is this the problem? If it is the problem, how can I fix it?

This is my first attempt at packaging for the Play store and there seems to be differing docs about how to do this. To add to my confusion, this project has been through a few versions of cordova and touch and has been worked on by other developers so there may well be older config files lying around.

Can provide more details once I know what I am supposed to be looking at.

Thanks,
AIDev