Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Turning off Touch support!

  1. #1
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default Turning off Touch support!

    Hi,

    I have spent a lot of time chasing issues in Chromium based browsers (tried 4 different ones) on my (new M3800) machine that do not affect anyone else.

    Just found out why msgTarget gets set to 'side' rather than 'qtip' for instance, and it's because my machine has a touch screen, so Ext.supports.Touch is set.

    There is a much bigger issue with column headers appearing in the wrong position, and the mouseover for the header trigger behaving strangely...

    I can't see a way of turning off touch. The Ext.supports values are set based on the outcomes of browsers tests...
    In my view it is essential to be able to disable features like this, especially when developing.

    Thoughts?

    Cheers,
    Westy
    Product Architect
    Altus Ltd.

  2. #2
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default

    Seems that turning off touch in the OS control panel (in Windows 7 64 bit) does not disable touch support in Ext either... I guess I'll try uninstalling the driver.

    I suppose another option is to force Ext.supports.Touch to false in application init or something?

    Edit: Nope, doing it in the application is far too late. I'll try altering bootstrap or maybe an override...
    Product Architect
    Altus Ltd.

  3. #3
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default

    Disabling touch in Chrome still causes the number of touch points to be retrieved, so ends up truthy.
    Product Architect
    Altus Ltd.

  4. #4
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default

    Arrgghh...

    We absolutely need to be able to turn off touch support.
    I have three monitors. Only one supports touch!

    Even with touch support I do not want the application to change it behaviour anyway to be honest.

    Going to raise an issue I think.
    Product Architect
    Altus Ltd.

  5. #5
    Sencha Premium Member steffenk's Avatar
    Join Date
    Jul 2007
    Location
    Haan, Germany
    Posts
    2,675
    Answers
    4

    Default

    at least you should be able to set this value, just find the right place to do after detect iwas called:
    Code:
    Ext.supports = {};
    Ext.feature.detect();
    Ext.supports.Touch = false;
    vg Steffen
    --------------------------------------
    Release Manager of TYPO3 4.5

  6. #6
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default

    The problem is doing it early enough, since it's used in the callback from Ext.define at times, e.g. Labelable.
    Product Architect
    Altus Ltd.

  7. #7
    Sencha User slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165
    Answers
    505

    Default

    Hi,

    The browser will report itself as touch enabled on Chrome on Windows touch-enabled machines. Which is correct, but may not always be desirable. There is a discussion internally currently as to if / how to allow for an opt-out path whether that would be globally, per device profile, per widget, etc.

  8. #8
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default

    Thanks for the response. I look forward to a solution.
    Product Architect
    Altus Ltd.

  9. #9
    Sencha User
    Join Date
    Mar 2016
    Posts
    97
    Answers
    5

    Default

    Was there any solution to this?

  10. #10
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Answers
    3

    Default

    Quote Originally Posted by llamerr View Post
    Was there any solution to this?
    Hi,

    I found no reliable way in the Ext codebase.

    The way I have had to do it, and others have done it here, is to disable the touchscreen HID device in task manager.
    It can be a pain to find the right one, but once done it sorts it.

    Of course, it means you cannot use touch in any application, but I don't mind living with that since I don't think touch is a great interface for a laptop, personally.

    Hope that helps,
    Westy


    Touchscreen HID.PNG
    Product Architect
    Altus Ltd.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •