Results 1 to 3 of 3

Thread: Custom theme css file is re-generated without including css from template SCSS files

    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-5395 in Architect 3.0.2.
  1. #1

    Default Custom theme css file is re-generated without including css from template SCSS files


    I don't know if the subject gave a hint about my problem but here is the long version: First of all I'm using Architect and we are trying to develop a Touch app. And also we are very new to both Architect and Touch. So we mostly follow the documentation and try to figure out the role of files by tracking file changes through SVN (try to analyze which files have changed after we take an action).

    We created and applied a custom theme using the default theme in Touch. After that we've seen that under our projects theme folder a css file is generated (sencha-touch-47572303-809b-4c71-9b57-62411ed0b75d.css). We figured that it's an auto generated css file that keeps our custom theme.

    After a while we've done some UI work, used a list and to it's tpl we've added a "Scss resource". These all worked perfectly. We have also seen that after adding these "Scss resources" to a list an auto-generated class name is added to the list and also the generated CSS from the Scss resources are also added to our auto generated css file under theme folder.

    But the things started to get weird after we had more than one list with Scss resources or after we make style change in another part of the code: I can not say what exactly but the problem is sometimes the auto-generated css file (sencha-touch-47572303-809b-4c71-9b57-62411ed0b75d.css) is generated without including template SCSS files (We see it from the file difference). Everything is in place, Scss resources are there but they are not included in the generated css. So we open the forms, panels, etc. and change "10" to "100" and save Scss. And then revert back "100" to "10" and save again to regenerate the CSS from Scss so it gets included to our theme css file.

    At first we didn't have that much design and we didn't know what was going on so we were repeating the above fix again and again. But now it's getting really hard to do that all the time.

    Does anyone else experience the same problem? If so, is it a bug or is it something that we do wrong?

    Thanks in advance

  2. #2
    Sencha User
    Join Date
    Jun 2010


    Sorry you're running into issues!

    I tried to reproduce it myself and I think I found the reason. It seems to happen when the instances in the inspector are "unloaded" e.g. they have the little "refresh" icon next to them. If you expand the top-level instances, it should compile normally. This is definitely a bug in Architect and we'll work on fixing it.

    Thanks for reporting the bug!

  3. #3


    Thanks for spending time to reproduce it! It's nice to be heard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts