Results 1 to 4 of 4

Thread: Detecting IE11

  1. #1
    Sencha Premium Member
    Join Date
    Mar 2007
    Posts
    97
    Answers
    1

    Default Answered: Detecting IE11

    Hi

    I am trying to detect IE in IE11. One thing I have noticed is that isIE returns false and that the user agent is set to
    "mozilla/5.0 (windows nt 6.1; wow64; trident/7.0; slcc2; .net clr 2.0.50727; .net clr 3.5.30729; .net clr 3.0.30729; media center pc 6.0; infopath.3; .net4.0c; .net4.0e; rv:11.0) like gecko"

    The detection of IE is looking for the string msie but this is not present.

    Anyone else had this issue or is there a workaround?

    Thanks

  2. This was reported as a bug issue recently and we are looking into a solution. The check is done on msie which the other IE browsers report but IE11 reports trident so it isn't detected properly.

  3. #2
    Sencha User
    Join Date
    Nov 2012
    Posts
    432
    Answers
    11

    Default

    This was reported as a bug issue recently and we are looking into a solution. The check is done on msie which the other IE browsers report but IE11 reports trident so it isn't detected properly.

  4. #3
    Sencha Premium Member
    Join Date
    Mar 2007
    Posts
    97
    Answers
    1

    Default

    Thanks for that, I will see if I can hack the code temporarily!

  5. #4
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Looks like this was fixed and released in 4.2.2.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •