Results 1 to 3 of 3

Thread: Unable to use strict doctype in IE

  1. #1
    Sencha Premium User
    Join Date
    Jun 2011
    Posts
    76

    Default Unable to use strict doctype in IE

    I'm currently using the following doctype in my GXT 2.3 app -
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">


    I'm trying to change to the following -
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

    which works in Chrome but not IE9.

    When using IE9 I get a load of error messages (see below). Any ideas how to fix this? thanks.

    doctype.jpg

  2. #2
    Sencha Premium User
    Join Date
    Jun 2011
    Posts
    76

    Default

    Any ideas on this one please?

  3. #3
    Sencha User
    Join Date
    Feb 2009
    Location
    Minnesota
    Posts
    2,737

    Default

    Can you specify which version of GWT and GXT you are using, and perhaps the contents of your module file? The error seems to indicate that IE9 is not supported by the GWT configuration you are using, either from too old of a version, or from having explicitly turned it off.

    The purpose of the UserAgentAsserter is to make sure that you never use a user.agent value that doesn't make sense for the current browser. If it thinks that something is out of sorts, it usually will serve as a canary for future problems you will face.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •