Results 1 to 4 of 4

Thread: Theme Fail: failed to render widgets within 30 sec.

  1. #1

    Default Theme Fail: failed to render widgets within 30 sec.

    Great progress has been made setting up and optimizing build in Cmd v3.0.0.250, however, at random build fails with this message:

    phantom.js process exited with code 1:
    loading page resources/theme/_notes/theme.html
    failed to render widgets within 30 sec.


    Why does this fail randomly?

    Is there a work around?

    Will upgrading fix this?

    Thanks!
    This is important. : )

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,379

    Default

    I have not had this issue with any of my apps.
    Mitchell Simoens @LikelyMitch

    Check out my GitHub:
    https://github.com/mitchellsimoens

    Posts are my own, not any current, past or future employer's.

  3. #3
    Sencha User Misiu's Avatar
    Join Date
    Jun 2012
    Location
    Poland
    Posts
    260

    Default

    I had the same problem.
    Do You have Ruby, sass and compass installed?

    This is maybe not related but after installing this in my system my builds are finally successful
    I'm using CMD v3.0.0.250

  4. #4
    Sencha Premium Member
    Join Date
    Sep 2011
    Posts
    51

    Default

    I get the same error, but substituting the exe from phantomjs.org didn't fix it... Several of my colleagues get this error as well. In their case, a Windows error dialog pops up indicating that phantomjs has terminated; then, the sencha build process seems to complete normally. I get no Windows error dialog; the build simply fails with lots of errors (as shown in OP).

    Does anyone at Sencha know what's causing this and/or whether there's a workaround?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •