Results 1 to 5 of 5

Thread: Padding is not getting applied for radiogroup

  1. #1
    Sencha User
    Join Date
    Jun 2012
    Location
    India
    Posts
    50
    Answers
    4

    Default Padding is not getting applied for radiogroup

    Padding is not getting applied to the radiogroup element.

  2. #2
    Sencha Premium User suzuki1100nz's Avatar
    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    716
    Answers
    45

    Default

    Your going to have to provide more than that if you want some help.

  3. #3
    Sencha User
    Join Date
    Jun 2012
    Location
    India
    Posts
    50
    Answers
    4

    Default

    Ext.create('Ext.form.Panel', {
    title: 'RadioGroup Example',
    width: 300,
    height: 125,
    bodyPadding: 10,
    renderTo: Ext.getBody(),
    items:[{
    xtype: 'radiogroup',
    fieldLabel: 'Two Columns',
    padding : '0 0 0 50',
    // Arrange radio buttons into two columns, distributed vertically
    columns: 2,
    vertical: true,
    items: [
    { boxLabel: 'Item 1', name: 'rb', inputValue: '1' },
    { boxLabel: 'Item 2', name: 'rb', inputValue: '2', checked: true},
    { boxLabel: 'Item 3', name: 'rb', inputValue: '3' },
    { boxLabel: 'Item 4', name: 'rb', inputValue: '4' },
    { boxLabel: 'Item 5', name: 'rb', inputValue: '5' },
    { boxLabel: 'Item 6', name: 'rb', inputValue: '6' }
    ]
    }]
    });

    In the above code i am setting the left padding of 50px to radiogroup. But i dont actually see the effect of padding on radiogroup element. Padding config is documented for the xtype radiogroup.

  4. #4
    Sencha Premium User suzuki1100nz's Avatar
    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    716
    Answers
    45

    Default

    Hi,
    Your correct, padding config isn't working on a radio group.
    Try margin - that works.
    Also better approach is to apply a css class to cls and style that.

  5. #5
    Sencha User
    Join Date
    Jun 2012
    Location
    India
    Posts
    50
    Answers
    4

    Default

    Thank you suzuki1100nz, margin worked!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •