Results 1 to 4 of 4

Thread: Extjs 3 to 4 migration

  1. #1

    Default Extjs 3 to 4 migration

    Hi,
    I am migrating my application from ext3 version to 4. while debuging with firebug, firebug console displayed following error in ext.all.debug.js file of ext4 line

    invalid 'in' operand parent
    <CODE>
    if (!('$class' in parent)) { for (i in basePrototype) {

    if (!parentPrototype[i]) {

    parentPrototype[i] = basePrototype[i];

    }

    }

    }
    </CODE>
    ext-all-debug.js(line 3348) ext4

    Please someone help me with this issue. waiting for the reply...

    Thanks
    Ashwin
    Last edited by raiwinashu; 12 Jun 2012 at 4:35 AM. Reason: code not displayed properly

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,410
    Answers
    716

    Default

    If you check your call stack, do you see what line is directing you to this error?

    You should be using ext-all-dev.js when converting over and clear up all the recommended corrections before you begin to debug.

    Scott.

  3. #3

    Default

    Hi,
    Thanks for your reply.
    I tried with ext-all-dev.js, still i am getting same error, (ext-all-dev.js line5677)

    Thanks
    Ashwin

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,410
    Answers
    716

    Default

    Understood, but are there any warnings/suggestion in the console that need to be cleared up based on using the -dev include.

    Scott.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •