Results 1 to 6 of 6

Thread: so slowly on element blur

  1. #1
    Sencha User
    Join Date
    Jul 2010
    Location
    XiaMen China
    Posts
    30

    Default so slowly on element blur

    my computer is Inter(R) Xeon(R) cpu,1G RAM,IE8
    when I start editing another cell,the last cell will trigger blur action,I finally find this code in ext-all-debug.js
    Code:
    blur : function() {
    try{
    this.dom.blur();
    }catch(e){}
    return this;
    },
    I want to know why it so slow .pls following the screenshot below.
    无标题.jpg

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,410

    Default

    You will need to provide more detail about your application/OS/Browser than just timing screens.

    Regards,
    Scott.

  3. #3
    Sencha User
    Join Date
    Jul 2010
    Location
    XiaMen China
    Posts
    30

    Default

    Quote Originally Posted by scottmartin View Post
    You will need to provide more detail about your application/OS/Browser than just timing screens.

    Regards,
    Scott.
    thank you for reply.

    my computer parameter:
    Inter(R) Xeon(R) cpu
    1G RAM

    windows server 2003
    IE8

    I have an EditorGrid with over 200 column,when I process over 20 rows,it is so slow when I switch editing another cell.EditorGrid has performance issue on IE.it looks like having two stages to start editing,first go into the cell,second show the editor,this two stages are so clear that I even can't stand.
    here is my example app.
    app.jpg

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,410

    Default

    There are several issues here:

    -200 columns is just a large amount of columns. You may want to consider placing separate grids on a tab control based on some criteria ... some other approach.

    The user can only see 10 columns at time based on your screen. You are simply overtaxing.
    This is the main cause of your delay.

    -IE is just slow .. especially with 200 columns. If you try this in another browser, you will see major improvement. I understand that some users require IE, so that may be your requirement.

    Small note: 1G of RAM is low by today's standards. The OS is taking a chunk of this. You may want to consider upgrading this. This will help a little, but not the solution.

    Regards,
    Scott.

  5. #5
    Sencha User
    Join Date
    Jul 2010
    Location
    XiaMen China
    Posts
    30

    Default

    thank you.
    I know what you say,but I can't redesign the database,and still can't separate to more grid on tab,as the columns have relation with each other,also we have to meet the custom's requirements,they have some computer with 1G ram and single cpu.they also use IE .

    all I want is to do everything to improve performance,even 100ms,I need your suggestion.
    looking forward to this.

    regards!

  6. #6
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,410

    Default

    I am not aware of any setting that correct this. What are your timings on Chrome? This will tell the tale of whether this is a code issue or a browser issue.

    If there is a drastic changes, it may worth having a meeting with your customer and simply show the difference.
    I know some companies are 'stuck' with IE, so this may be a moot point, but worth your time to research.

    Regards,
    Scott.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •