Results 1 to 2 of 2

Thread: proxy headers getting \n when using a +

    This duplicates another bug already reported in our system: DSGNR-1782
  1. #1
    Sencha User
    Join Date
    Mar 2012
    Posts
    28

    Default proxy headers getting \n when using a +

    Hey,

    I'm trying to define a header on my ajaxproxy but when i place a + inside the command it places \n all over the header.

    Code:
    {
    Accept: 'application/json',
    BackendMode: 'jpa',
    'Authorization': 'Basic ' + Base64.encode(App.Settings.user + ":" + App.Settings.password)
    }
    but this gets generated as

    Code:
    {\nAccept: \'application/json\',\nBackendMode: \'jpa\',\n\'Authorization\': \'Basic \' + Base64.encode(App.Settings.user + ":" + App.Settings.password)\n}
    any idea how i could fix this? or should i report this as a bug?

  2. #2
    Sencha User
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    If you want to use methods or variables in your configuration you need to create an override. The property grid accepts primitive values only.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •